<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
  <meta content="text/html;charset=ISO-8859-1" http-equiv="Content-Type">
</head>
<body bgcolor="#ffffff" text="#000000">
Johannes Stezenbach wrote:
<blockquote cite="mid20050331114308.GA13961@linuxtv.org" type="cite">
  <pre wrap="">Helmut Auer wrote:
  </pre>
  <blockquote type="cite">
    <pre wrap="">I just tried to install my twinhan 1025 as described in README.bt8xx with 
cvs from 21.03. but modprobe bttv hangs up the system with kernel 2.6.11
    </pre>
  </blockquote>
  <pre wrap="">I heard three similar reports now, but I'm quite sure it worked for me
with 2.6.11 (will re-try later).
  </pre>
</blockquote>
I have this problem for some time with any kernel after 2.6.11-rc3. I'm
using 2.6.10 right now and it is working fine.<br>
<blockquote cite="mid20050331114308.GA13961@linuxtv.org" type="cite">
  <pre wrap="">What's the last line of output from the boot messages?
  </pre>
</blockquote>
Here are the last line from syslog using 2.6.11.4:<br>
<blockquote><code>Linux video capture interface: v1.00<br>
bttv: driver version 0.9.15 loaded<br>
bttv: using 8 buffers with 2080k (520 pages) each for capture<br>
bttv: Bt8xx card found (0).<br>
ACPI: PCI interrupt 0000:00:0a.0[A] -&gt; GSI 10 (level, low) -&gt; IRQ
10<br>
bttv0: Bt878 (rev 17) at 0000:00:0a.0, irq: 10, latency: 32, mmio:
0xe7800000<br>
bttv0: detected: Twinhan VisionPlus DVB-T [card=113], PCI subsystem ID
is 1822:0001<br>
bttv0: using: Twinhan DST + clones [card=113,autodetected]<br>
bttv0: gpio: en=00000000, out=00000000 in=00f5ffff [init]<br>
  </code></blockquote>
And for comparation, here is the output from 2.6.10 on the same system
(2.6.10 is work fine):<br>
<blockquote><code>Linux video capture interface: v1.00<br>
bttv: driver version 0.9.15 loaded<br>
bttv: using 8 buffers with 2080k (520 pages) each for capture<br>
bttv: Bt8xx card found (0).<br>
ACPI: PCI interrupt 0000:00:0a.0[A] -&gt; GSI 10 (level, low) -&gt; IRQ
10<br>
bttv0: Bt878 (rev 17) at 0000:00:0a.0, irq: 10, latency: 32, mmio:
0xe7800000<br>
bttv0: detected: Twinhan VisionPlus DVB-T [card=113], PCI subsystem ID
is 1822:0001<br>
bttv0: using: Twinhan DST + clones [card=113,autodetected]<br>
bttv0: gpio: en=00000000, out=00000000 in=00f5ffff [init]<br>
bttv0: using tuner=4<br>
bttv0: add subdevice "dvb0"<br>
bt878(0): Bt878 (rev 17) at 00:0a.1, irq: 10, latency: 32, memory:
0xe7000000<br>
DVB: registering new adapter (bttv0).<br>
dst_check_ci: recognize DST-03T<br>
DST type : satellite<br>
DST type flags : 0x2 ts204 0x4 symdiv<br>
DVB: registering frontend 0 (DST DVB-S)...<br>
  </code></blockquote>
<blockquote cite="mid20050331114308.GA13961@linuxtv.org" type="cite">
  <pre wrap="">Specifically, does it crash when loading bttv or dvb-bt8xx?
  </pre>
</blockquote>
The system just freeze when loading bttv driver. I was able to capture
this line from syslog because I have a dedicated system for logging.<br>
<blockquote cite="mid20050331114308.GA13961@linuxtv.org" type="cite">
  <pre wrap="">And, more important, does the problem still exist in 2.6.12-rc1-bk3?
  </pre>
</blockquote>
I have tested and the problems is still in 2.6.12-rc1-bk3.<br>
I have also tried to move my DVB board to different systems and I see
same hang when loading bttv. I have tried P3 and P4 systems with SiS,
VIA and Intel chipsets.<br>
<br>
Thanks,<br>
Jake<br>
</body>
</html>