Sorry, for some reason it has now stopped working with knoppix and <a href="http://2.6.11.12">2.6.11.12</a>. Will try to find out more this weekend.<br>
<br>
Paul<br><br><div><span class="gmail_quote">On 9/15/05, <b class="gmail_sendername">Paul Wheeler</b> &lt;<a href="mailto:paulrwheeler@gmail.com">paulrwheeler@gmail.com</a>&gt; wrote:</span><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
Ronnie, Miguel thanks for both of your quick replies.<br>
<br>
Right I from my understanding of the problems I believe that a &quot;race&quot;
is going on as to when this card is detected. I think that it is most
likely in the i2c part of the driver (more justification below). So I
have two questions:<br>
<br>
1) Seeing as the card works in most cases do the driver writers have
the time and inclination to help find this bug? I am happy to put a lot
of effort into testing and narrowing down where the problem might lie
however I have done no kernel coding (but do know c++ well and am happy
to play with kernel source code but wont know what am doing with it). I
dont want to put all this effort in though for noone to use it.<br>
<br>
2) Is this the right list for the problem? It is a dvb card though I
dont know whether it is the mt352.c or the bttv-i2c.c files (maybe even
some more generic i2c code) AFAIK the mt352.c is 'maintained' on this
list whereas the bttv-i2c.c is on the v4l list. Is this correct?<br>
<br>
<br>
My reasons for thinking it is a race: My problem started when i changed
the power supply, thats it worked fine before changed the power supply
and stopped. I tried the card in another machine it worked so thought I
must have damaged the motherboard. So changed the motherboard and the
same problem. The card worked in one machine and not another even
though both had identical kernels. However I thought as a last attempt
would try a knoppix CD to see if that worked and it did so installed
vanilla-2.6.11.12 kernel and it worked again. So it consistently works
with 2.6.11 and fails with 2.6.13 on one machine but works with 2.6.13
on anaother. So the problem can be sorted by both hardware and software
changes (seemingly independent). If it can be assumed that both of
these cause and solve the same bug then the bug must be in both
hardware and software, the only way this could happen is a &quot;race&quot; which
is affected by hardware.<br>
<br>
This fits with both Ronny and Miguel's experience. Ronny can seem to affect the race by leaving his power supply plugged in.<br>
<br>
Ronny, Miguel I would be interested to know if either of you have any
problems with the either the vanilla <a href="http://2.6.11.12" target="_blank" onclick="return top.js.OpenExtLink(window,event,this)">2.6.11.12</a> kernel or the latest
version of knoppix 3.9? If you dont then this race has been introduced
since then. I would also like to hear from anyone else who has had this
problem and if it is consistent/different from above.<br>
<br>
Many thanks<br>
<br>
Paul<br>
<br>
P.S. bit more info. The problem only happens at boot, if it is detected
fine it works perfectly till next reboot, if not then wont work till
(possible) next reboot. I have had the card working then reboot the
machine without changing anything software wise and it stops working.<div><span class="e" id="q_1065a0093b5f1d86_1"><br><br><div><span class="gmail_quote">On 9/14/05, <b class="gmail_sendername">Miguel Yarza</b> &lt;<a href="mailto:yarza@euskalnet.net" target="_blank" onclick="return top.js.OpenExtLink(window,event,this)">
yarza@euskalnet.net
</a>&gt; wrote:</span><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">Paul Wheeler wrote:<br><br>&gt;I have searched the list and the net to try and find a solution to this but
<br>&gt;so far unsuccessfull. The problem is that the dvb frontend is not found. I<br>&gt;have tried on a different motherboard and still same problem however a<br>&gt;different computer it works fine.<br>&gt;<br>&gt;I get the following in dmesg
<br>&gt;<br>&gt;mt352_read_register: readreg error (reg=127, ret==-5)<br>&gt;dvb-bt8xx: A frontend driver was not found for device 109e/0878<br>&gt;subsystem 1461/0771<br>&gt;<br>&gt;In both machines I am using Gentoo-2.6.13-r1

 kernel.<br>&gt;<br>&gt;The motherboards that it fails on are:<br>&gt;<br>&gt;asus p4p800s-x and an aopen intel 865 board<br>&gt;<br>&gt;it works fine in my shuttle sn41g2.<br>&gt;<br>&gt;I have tried all possible hardware fixes.
<br>&gt;<br>&gt;The card is recognized to begin with on the motherboard(asus) but after a<br>&gt;reboot stops and hasnt worked since!!<br>&gt;<br>&gt;I have noticed others who have had this problem before but no solution is
<br>&gt;posted. Could people possible post what motherboard they have if the card<br>&gt;works or how they solved this problem if they had it before.<br>&gt;<br>&gt;Cheers<br>&gt;<br>&gt;Paul<br>&gt;<br>&gt;<br>Same problem here:
<br> - the card works great with Shuttle SN41G2 k7 nforce2 chipset<br> - but on a K7 ASUS A7N8X-E DELUXE (k7 nforce2 chipset too)&nbsp;&nbsp;&quot;modprobe<br>dvb-bt8xx&quot; says:<br><br>Sep 14 01:17:23 topocasa kernel: DVB: registering new adapter (bttv0).
<br>Sep 14 01:17:23 topocasa kernel: mt352_read_register: readreg error<br>(reg=127, ret==-5)<br>Sep 14 01:17:23 topocasa kernel: dvb-bt8xx: A frontend driver was not<br>found for device 109e/0878 subsystem 1461/0771<br>
<br>
Same error with different kernels since 2.6.10 and snapshots from cvs,<br>last try with 2.6.12-6 from debian.<br>In the hardware front tried with different slots and card combinations,<br>no luck.<br>A difference with Paul's card behavior is that mine has never been
<br>recognized.<br><br>Cheers<br><br>&nbsp;&nbsp; Miguel<br><br>_______________________________________________<br>linux-dvb mailing list<br><a href="mailto:linux-dvb@linuxtv.org" target="_blank" onclick="return top.js.OpenExtLink(window,event,this)">
linux-dvb@linuxtv.org</a><br><a href="http://www.linuxtv.org/cgi-bin/mailman/listinfo/linux-dvb" target="_blank" onclick="return top.js.OpenExtLink(window,event,this)">
http://www.linuxtv.org/cgi-bin/mailman/listinfo/linux-dvb</a><br></blockquote></div><br>

</span></div></blockquote></div><br>