<HTML><BODY style="word-wrap: break-word; -khtml-nbsp-mode: space; -khtml-line-break: after-white-space; ">Johannes,<DIV><BR class="khtml-block-placeholder"></DIV><DIV>I managed to get my Yellow Dog kernel up from 2.6.10 to 2.6.14.3</DIV><DIV>(clean download, not patched). The Freecom USB stick is now</DIV><DIV>detected but I get the same problems as Michael Hanke recently</DIV><DIV>reported (thread subject "dnt Euro Stick DVB-T -- FATAL: FE_GET_INFO</DIV><DIV><SPAN class="Apple-style-span">failed:<SPAN class="Apple-tab-span" style="white-space:pre">        </SPAN>22") wher<FONT class="Apple-style-span" color="#000000"><SPAN class="Apple-style-span" style="background-color: transparent;">e the device won't tune. The Freecom works fine</SPAN></FONT></SPAN></DIV><DIV><FONT class="Apple-style-span" color="#000000"><SPAN class="Apple-style-span" style="background-color: transparent;">with EyeTV under MacOS X, no tuning problems or issues associated</SPAN></FONT></DIV><DIV><FONT class="Apple-style-span" color="#000000"><SPAN class="Apple-style-span" style="background-color: transparent;">with input signal saturation as reported by Mike Choy (thread subject</SPAN></FONT></DIV><DIV><FONT class="Apple-style-span" color="#000000"><SPAN class="Apple-style-span" style="background-color: transparent;">"freecom dvb-t usb firmware coldstate") so there's nothing wrong with</SPAN></FONT></DIV><DIV><FONT class="Apple-style-span" color="#000000"><SPAN class="Apple-style-span" style="background-color: transparent;">the stick or the aerial feed. But I get the same "recv bulk message</SPAN></FONT></DIV><DIV><FONT class="Apple-style-span" color="#000000"><SPAN class="Apple-style-span" style="background-color: transparent;">failed: -110" as everyone else under Linux.</SPAN></FONT></DIV><DIV><BR class="khtml-block-placeholder"></DIV><DIV><FONT class="Apple-style-span" color="#000000"><SPAN class="Apple-style-span" style="background-color: transparent;">Here are the logs:</SPAN></FONT></DIV><DIV><FONT class="Apple-style-span" color="#000000"><SPAN class="Apple-style-span" style="background-color: transparent;"><BR class="khtml-block-placeholder"></SPAN></FONT></DIV><DIV><SPAN class="Apple-style-span"><FONT class="Apple-style-span" color="#000000"><SPAN class="Apple-style-span" style="background-color: transparent;">Freecom dmesg out</SPAN></FONT>put:</SPAN></DIV><DIV><BR class="khtml-block-placeholder"></DIV><DIV>usb 1-1: new high speed USB device using ehci_hcd and address 3</DIV><DIV>dvb-usb: found a 'WideView WT-220U PenType Receiver (Typhoon/Freecom)' in warm state.</DIV><DIV>dvb-usb: will use the device's hardware PID filter (table count: 15).</DIV><DIV>DVB: registering new adapter (WideView WT-220U PenType Receiver (Typhoon/Freecom)).</DIV><DIV>DVB: registering frontend 0 (WideView USB DVB-T)...</DIV><DIV>dvb-usb: schedule remote query interval to 300 msecs.</DIV><DIV>dvb-usb: WideView WT-220U PenType Receiver (Typhoon/Freecom) successfully initialized and connected.</DIV><DIV>dvb-usb: recv bulk message failed: -110</DIV><DIV><BR class="khtml-block-placeholder"></DIV><DIV>Freecom tzap output:</DIV><DIV><BR class="khtml-block-placeholder"></DIV><DIV>[root@yellowdog build-2.6]# tzap -r -a 0 -x BBCNews24</DIV><DIV>using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'</DIV><DIV>tuning to 778000000 Hz</DIV><DIV>freq: 778000000, inversion: 0, bw: 0, crHP: 3, crLP: 0, mod: 1, mode: 0, guard: 0, hier: 0</DIV><DIV>video pid 0x0280, audio pid 0x0281</DIV><DIV>status 1f | signal 3434 | snr e9e9 | ber 00000000 | unc 00000000 | FE_HAS_LOCK[root@yellowdog build-2.6]#</DIV><DIV><BR class="khtml-block-placeholder"></DIV><DIV>Freecom scan output:</DIV><DIV><BR class="khtml-block-placeholder"></DIV><DIV>[root@yellowdog build-2.6]# scan -c</DIV><DIV>using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'</DIV><DIV>WARNING: filter timeout pid 0x0011</DIV><DIV>WARNING: filter timeout pid 0x0000</DIV><DIV>dumping lists (0 services)</DIV><DIV>Done.</DIV><DIV>[root@yellowdog build-2.6]#               </DIV><DIV><BR class="khtml-block-placeholder"></DIV><DIV><BR class="khtml-block-placeholder"></DIV><DIV>I tried the DEC2000-t with the new kernel, same problem as before, here</DIV><DIV>are the logs for that:</DIV><DIV><BR class="khtml-block-placeholder"></DIV><DIV>DEC2000-t dmesg output:</DIV><DIV><BR class="khtml-block-placeholder"></DIV><DIV>usb 4-1: new full speed USB device using ohci_hcd and address 2</DIV><DIV>ttusb_dec: Firmware 1.05de</DIV><DIV>Oops: kernel access of bad area, sig: 11 [#1]</DIV><DIV>NIP: C0012168 LR: C01609EC SP: EFF2BC60 REGS: eff2bbb0 TRAP: 0300    Not tainted</DIV><DIV>MSR: 00009032 EE: 1 PR: 0 FP: 0 ME: 1 IR/DR: 11</DIV><DIV>DAR: 00000000, DSISR: 40000000</DIV><DIV>TASK = c0608bd0[31] 'khubd' THREAD: eff2a000</DIV><DIV>Last syscall: -1</DIV><DIV>GPR00: C01EC704 EFF2BC60 C0608BD0 00000000 FFFFFFFF 0000001E 00000000 000001A4</DIV><DIV>GPR08: 00000000 00000000 C01ECDDC C01ECC20 00000000 00000000 C18D6418 C18B4890</DIV><DIV>GPR16: 00000004 C18B48E2 C18A7E30 C03D0000 C0290000 C0380000 F22E0000 00000001</DIV><DIV>GPR24: 00000000 EFF2BD7C EDC1C860 00000000 0000001E 00000000 C0684120 C0684120</DIV><DIV>NIP [c0012168] strlen+0x4/0x18</DIV><DIV>LR [c01609ec] strlcpy+0x24/0x70</DIV><DIV>Call trace:</DIV><DIV> [c01ec704] _request_firmware+0xc8/0x37c</DIV><DIV> [f22dbe6c] ttusb_dec_probe+0x2ac/0xc58 [ttusb_dec]</DIV><DIV> [c028336c] usb_probe_interface+0x78/0xa8</DIV><DIV> [c01e7540] driver_probe_device+0x50/0xf4</DIV><DIV> [c01e6ae0] bus_for_each_drv+0x60/0xb4</DIV><DIV> [c01e74ac] device_attach+0x98/0xdc</DIV><DIV> [c01e696c] bus_add_device+0x40/0x154</DIV><DIV> [c01e529c] device_add+0x114/0x174</DIV><DIV> [c028b880] usb_set_configuration+0x2d0/0x488</DIV><DIV> [c02862c0] usb_new_device+0x15c/0x214</DIV><DIV> [c0287464] hub_thread+0x960/0xd18</DIV><DIV> [c0036604] kthread+0xf0/0x12c</DIV><DIV> [c000756c] kernel_thread+0x44/0x60</DIV><DIV>[root@yellowdog build-2.6]#    </DIV><DIV><BR class="khtml-block-placeholder"></DIV><DIV><BR class="khtml-block-placeholder"></DIV><DIV>Regards,</DIV><DIV><BR class="khtml-block-placeholder"></DIV><DIV>Tim.</DIV><DIV><BR class="khtml-block-placeholder"></DIV><DIV><BR><DIV><DIV>On 7 Dec 2005, at 14:53, Johannes Stezenbach wrote:</DIV><BR class="Apple-interchange-newline"><BLOCKQUOTE type="cite"><DIV style="margin-top: 0px; margin-right: 0px; margin-bottom: 0px; margin-left: 0px; ">On Mon, Dec 05, 2005, Tim Hewett wrote:</DIV> <BLOCKQUOTE type="cite"><DIV style="margin-top: 0px; margin-right: 0px; margin-bottom: 0px; margin-left: 0px; ">I'm trying to get the current CVS of Linux DVB working on an Apple iBook</DIV><DIV style="margin-top: 0px; margin-right: 0px; margin-bottom: 0px; margin-left: 0px; ">running Yellow Dog using either a Hauppauge DEC2000-t (which works</DIV><DIV style="margin-top: 0px; margin-right: 0px; margin-bottom: 0px; margin-left: 0px; ">fine on a Pentium III with Mandrake 9.1) and also a Freecom DVB-T USB</DIV><DIV style="margin-top: 0px; margin-right: 0px; margin-bottom: 0px; margin-left: 0px; ">stick. Neither work. The drivers build ok once the makefile is setup <SPAN class="Apple-converted-space"> </SPAN></DIV><DIV style="margin-top: 0px; margin-right: 0px; margin-bottom: 0px; margin-left: 0px; ">to find</DIV><DIV style="margin-top: 0px; margin-right: 0px; margin-bottom: 0px; margin-left: 0px; ">the source and the kernel config file in the right places, and they <SPAN class="Apple-converted-space"> </SPAN></DIV><DIV style="margin-top: 0px; margin-right: 0px; margin-bottom: 0px; margin-left: 0px; ">load but</DIV><DIV style="margin-top: 0px; margin-right: 0px; margin-bottom: 0px; margin-left: 0px; ">every time the Hauppauge device is connected the kernel hits an <SPAN class="Apple-converted-space"> </SPAN></DIV><DIV style="margin-top: 0px; margin-right: 0px; margin-bottom: 0px; margin-left: 0px; ">exception</DIV><DIV style="margin-top: 0px; margin-right: 0px; margin-bottom: 0px; margin-left: 0px; ">and the Freecom isn't recognised at all (though maybe the latter is <SPAN class="Apple-converted-space"> </SPAN></DIV><DIV style="margin-top: 0px; margin-right: 0px; margin-bottom: 0px; margin-left: 0px; ">because</DIV><DIV style="margin-top: 0px; margin-right: 0px; margin-bottom: 0px; margin-left: 0px; ">the kernel is only 2.6.10).</DIV><DIV style="margin-top: 0px; margin-right: 0px; margin-bottom: 0px; margin-left: 0px; min-height: 14px; "><BR></DIV><DIV style="margin-top: 0px; margin-right: 0px; margin-bottom: 0px; margin-left: 0px; ">I am wondering if the DVB drivers are only for the Intel architecture,</DIV><DIV style="margin-top: 0px; margin-right: 0px; margin-bottom: 0px; margin-left: 0px; ">or does the byte endian issue sort itself out automatically? Has anyone</DIV><DIV style="margin-top: 0px; margin-right: 0px; margin-bottom: 0px; margin-left: 0px; ">had any DVB devices working at all on PowerPC?</DIV> </BLOCKQUOTE><DIV style="margin-top: 0px; margin-right: 0px; margin-bottom: 0px; margin-left: 0px; min-height: 14px; "><BR></DIV><DIV style="margin-top: 0px; margin-right: 0px; margin-bottom: 0px; margin-left: 0px; ">They obviously don't get as many testers on non-x86 architectures.</DIV><DIV style="margin-top: 0px; margin-right: 0px; margin-bottom: 0px; margin-left: 0px; min-height: 14px; "><BR></DIV><DIV style="margin-top: 0px; margin-right: 0px; margin-bottom: 0px; margin-left: 0px; ">If you care about getting the DEC2000-t driver fixed you need to post</DIV><DIV style="margin-top: 0px; margin-right: 0px; margin-bottom: 0px; margin-left: 0px; ">some useful info like the Oops message. Maybe someone can figure out</DIV><DIV style="margin-top: 0px; margin-right: 0px; margin-bottom: 0px; margin-left: 0px; ">what's wrong then.</DIV><DIV style="margin-top: 0px; margin-right: 0px; margin-bottom: 0px; margin-left: 0px; min-height: 14px; "><BR></DIV><DIV style="margin-top: 0px; margin-right: 0px; margin-bottom: 0px; margin-left: 0px; ">Johannes</DIV><DIV style="margin-top: 0px; margin-right: 0px; margin-bottom: 0px; margin-left: 0px; min-height: 14px; "><BR></DIV> </BLOCKQUOTE></DIV><BR></DIV></BODY></HTML>