Next test on this, was compiling and trying mercurial sources of dvb-apps.<br>Again, no luck with scan command, but dvbscan reported &quot;Unable to query frontend status&quot;, even when frontend0 seems alive.<br>I enclose the report with strace here:
<br><br>#strace ./dvbscan -frontend 0 ../scan/dvb-t/es-Madrid<br>execve(&quot;./dvbscan&quot;, [&quot;./dvbscan&quot;, &quot;-frontend&quot;, &quot;0&quot;, &quot;../scan/dvb-t/es-Madrid&quot;], [/* 22 vars */]) = 0<br>uname({sys=&quot;Linux&quot;, node=&quot;chaos&quot;, ...}) = 0
<br>brk(0)&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; = 0x8105000<br>brk(0x8105c40)&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; = 0x8105c40<br>set_thread_area({entry_number:-1 -&gt; 6, base_addr:0x8105800, limit:1048575, seg_32bit:1, contents:0, read_exec_only:0, limit_in_pages:1, seg_not_present:0, useable:1}) = 0
<br>brk(0x8126c40)&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; = 0x8126c40<br>brk(0x8127000)&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; = 0x8127000<br>getpid()&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; = 5423<br>rt_sigaction(SIGRTMIN, {0x8050ca0, [], 0}, NULL, 8) = 0<br>
rt_sigaction(SIGRT_1, {0x8050680, [RTMIN], 0}, NULL, 8) = 0<br>rt_sigaction(SIGRT_2, {0x804fed0, [], 0}, NULL, 8) = 0<br>rt_sigprocmask(SIG_BLOCK, [RTMIN], NULL, 8) = 0<br>rt_sigprocmask(SIG_UNBLOCK, [RT_1], NULL, 8) = 0<br>
open(&quot;/dev/dvb/adapter0/frontend0&quot;, O_RDWR) = 3<br>ioctl(3, 0x80a86f3d, 0xbfbe2d8c)&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; = 0<br>open(&quot;../scan/dvb-t/es-Madrid&quot;, O_RDONLY) = 4<br>fstat64(4, {st_mode=S_IFREG|0644, st_size=838, ...}) = 0
<br>mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0xb7fb4000<br>read(4, &quot;T 618000000 8MHz 2/3 1/2 QAM64 8&quot;..., 4096) = 838<br>read(4, &quot;&quot;, 4096)&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; = 0<br>
close(4)&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; = 0<br>munmap(0xb7fb4000, 4096)&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; = 0<br>ioctl(3, 0x40246f4c, 0xbfbe3d94)&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; = 0<br>time(NULL)&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; = 1167381014<br>time(NULL)&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; = 1167381014
<br>ioctl(3, 0x80046f45, 0xbfbe3e14)&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; = 0<br>write(2, &quot;Unable to query frontend status\n&quot;, 32Unable to query frontend status<br>) = 32<br>exit_group(1)&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; = ?<br>Process 5423 detached
<br><br>Any advice on this please?<br><br>Thanks.<br>Meu<br><br>---------- Forwarded message ----------<br><span class="gmail_quote">From: <b class="gmail_sendername">broza .</b> &lt;<a href="mailto:brozada@gmail.com">brozada@gmail.com
</a>&gt;<br>Date: Dec 27, 2006 9:43 PM<br>Subject: flydvb-t 301 not scanning<br>To: <a href="mailto:linux-dvb@linuxtv.org">linux-dvb@linuxtv.org</a><br><br></span>Hi,<br><br>I own a flyDVB-T card (saa7134) that is detected by current the kernel (
2.6.18 debian unstable for K7),<br>but don&#39;t works when trying to scan for dvb channels<br><br>Also, I&#39;ve tried with linuxtv mercurial sources, compiling and installing it without trouble, but again no luck with scanning.
<br><br>I enclose here more data:<br># lspci -vv<br>иии<br>00:0d.0 Multimedia controller: Philips Semiconductors SAA7134/SAA7135HL Video Broadcast Decoder (rev 01)<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Subsystem: Animation Technologies Inc. Unknown device 0301
<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium &gt;TAbort- &lt;TAbort- &lt;MAbort- &gt;SERR- &lt;PERR-
<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Latency: 32 (21000ns min, 8000ns max)<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Interrupt: pin A routed to IRQ 169<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Region 0: Memory at b4000000 (32-bit, non-prefetchable) [size=1K]<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Capabilities: [40] Power Management version 1
<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Status: D0 PME-Enable- DSel=0 DScale=1 PME-<br>иии<br><br>saa7134 part of dmesg:<br>saa7134[0]: found at 0000:00:
0d.0, rev: 1, irq: 169, latency: 32, mmio: 0xb4000000<br>saa7134[0]: subsystem: 5168:0301, board: LifeView FlyDVB-T / Genius VideoWonder DVB-T [card=86,autodetected]<br>saa7134[0]: board init: gpio is 10000<br>saa7134[0]/core: hwinit1
<br>input: saa7134 IR (LifeView FlyDVB-T / as /class/input/input3<br>saa7134[0]: i2c eeprom 00: 68 51 01 03 54 20 1c 00 43 43 a9 1c 55 d2 b2 92<br>saa7134[0]: i2c eeprom 10: 00 ff 86 0f ff 20 ff ff ff ff ff ff ff ff ff ff
<br>saa7134[0]: i2c eeprom 20: 01 40 01 02 03 ff 01 03 08 ff 01 08 ff ff ff ff<br>saa7134[0]: i2c eeprom 30: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff<br>saa7134[0]: i2c eeprom 40: ff 1b 00 c0 ff 10 ff ff ff ff ff ff ff ff ff ff
<br>saa7134[0]: i2c eeprom 50: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff<br>saa7134[0]: i2c eeprom 60: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff<br>saa7134[0]: i2c eeprom 70: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
<br>saa7134[0]/core: hwinit2<br>saa7134[0]/video: set tv norm = PAL<br>saa7134[0]/video: video input = 0 [Composite1]<br>saa7134[0]/video: set tv norm = PAL<br>saa7134[0]: registered device video1 [v4l2]<br>saa7134[0]: registered device vbi1
<br>saa7134[0]/video: DCSDT: pll: not locked, sync: no, norm: (no signal)<br>DVB: registering new adapter (saa7134[0]).<br>saa7134 ALSA driver for DMA sound loaded<br>saa7134[0]/alsa: saa7134[0] at 0xb4000000 irq 169 registered as card -1
<br>saa7134[0]/video: open minor=1 radio=0 type=video-cap<br>saa7134[0]/video: video input = 0 [Composite1]<br>saa7134[0]/video: set tv norm = PAL<br>saa7134[0]/video: set_control name=Brightness val=128<br>saa7134[0]/video: set_control name=Hue val=0
<br>saa7134[0]/video: set_control name=Contrast val=68<br>saa7134[0]/video: set_control name=Saturation val=64<br>saa7134[0]/video: set_control name=Brightness val=128<br>saa7134[0]/video: set_control name=Hue val=0<br>saa7134[0]/video: set_control name=Contrast val=68
<br>saa7134[0]/video: set_control name=Saturation val=64<br><br>tda10046 part:<br>tda1004x: setting up plls for 48MHz sampling clock<br>tda1004x: found firmware revision 23 -- ok<br><br>And scan result:<br>scan -v /usr/share/doc/dvb-utils/examples/scan/dvb-t/es-Madrid
<br>scanning /usr/share/doc/dvb-utils/examples/scan/dvb-t/es-Madrid<br>using &#39;/dev/dvb/adapter0/frontend0&#39; and &#39;/dev/dvb/adapter0/demux0&#39;<br>initial transponder 770000000 0 2 1 3 1 3 0<br>initial transponder 810000000 0 2 1 3 1 3 0
<br>initial transponder 834000000 0 2 1 3 1 3 0<br>initial transponder 842000000 0 2 1 3 1 3 0<br>initial transponder 850000000 0 2 1 3 1 3 0<br>initial transponder 858000000 0 2 1 3 1 3 0<br>&gt;&gt;&gt; tune to: 770000000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_2_3:FEC_1_2:QAM_64:TRANSMISSION_MODE_8K:GUARD_INTERVAL_1_4:HIERARCHY_NONE
<br>&gt;&gt;&gt; tuning status == 0x00<br>&gt;&gt;&gt; tuning status == 0x00<br>&gt;&gt;&gt; tuning status == 0x00<br>&gt;&gt;&gt; tuning status == 0x00<br>&gt;&gt;&gt; tuning status == 0x00<br>&gt;&gt;&gt; tuning status == 0x00
<br>&gt;&gt;&gt; tuning status == 0x00<br>&gt;&gt;&gt; tuning status == 0x00<br>&gt;&gt;&gt; tuning status == 0x00<br>&gt;&gt;&gt; tuning status == 0x00<br>WARNING: &gt;&gt;&gt; tuning failed!!!<br>&gt;&gt;&gt; tune to: 770000000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_2_3:FEC_1_2:QAM_64:TRANSMISSION_MODE_8K:GUARD_INTERVAL_1_4:HIERARCHY_NONE (tuning failed)
<br>&gt;&gt;&gt; tuning status == 0x00<br>&gt;&gt;&gt; tuning status == 0x00<br>&gt;&gt;&gt; tuning status == 0x00<br>&gt;&gt;&gt; tuning status == 0x00<br>&gt;&gt;&gt; tuning status == 0x00<br>&gt;&gt;&gt; tuning status == 0x00
<br>&gt;&gt;&gt; tuning status == 0x00<br>&gt;&gt;&gt; tuning status == 0x00<br>&gt;&gt;&gt; tuning status == 0x00<br>&gt;&gt;&gt; tuning status == 0x00<br>WARNING: &gt;&gt;&gt; tuning failed!!!<br>иии<br><br><br>Could anybody give me and advice on what happens?
<br><br>Thanks in advance<br><br>Meu<br><br><br><br><br>