Hi,<br><br>I just updated to latest code since I saw that there was a bunch of new changes for the dib0700, using:<br>hg pull -u <a href="http://linuxtv.org/hg/v4l-dvb">http://linuxtv.org/hg/v4l-dvb</a><br><br>Then when I compile I get this error:
<br><br>$ make<br>make -C /home/hgu/dtv/v4l-dvb/v4l <br>make[1]: Entering directory `/home/hgu/dtv/v4l-dvb/v4l&#39;<br>creating symbolic links...<br>make -C /lib/modules/2.6.20-16-generic/build SUBDIRS=/home/hgu/dtv/v4l-dvb/v4l&nbsp; modules
<br>make[2]: Entering directory `/usr/src/linux-headers-2.6.20-16-generic&#39;<br>&nbsp; Building modules, stage 2.<br>&nbsp; MODPOST 190 modules<br>WARNING: &quot;dib0070_wbd_offset&quot; [/home/hgu/dtv/v4l-dvb/v4l/dvb-usb-dib0700.ko
] undefined!<br>make[2]: Leaving directory `/usr/src/linux-headers-2.6.20-16-generic&#39;<br>./scripts/rmmod.pl check<br>found 190 modules<br>make[1]: Leaving directory `/home/hgu/dtv/v4l-dvb/v4l&#39;<br><br>Did a make clean first as well, this is the second make call.
<br><br>Did a search to try to find the issue in the v4l-dvb code, I&#39;m new to this code but to me it looks like it export the symbol:<br><br>$ grep -riI &#39;dib0070_wbd_offset&#39; *<br>linux/drivers/media/dvb/frontends/dib0070.c:u16 dib0070_wbd_offset(struct dvb_frontend *fe)
<br>linux/drivers/media/dvb/frontends/dib0070.c:EXPORT_SYMBOL(dib0070_wbd_offset);<br>linux/drivers/media/dvb/frontends/dib0070.h:extern u16 dib0070_wbd_offset(struct dvb_frontend *);<br>linux/drivers/media/dvb/dvb-usb/dib0700_devices.c:&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; deb_info(&quot;WBD for DiB7000P: %d\n&quot;, offset + dib0070_wbd_offset(fe));
<br>linux/drivers/media/dvb/dvb-usb/dib0700_devices.c:&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; dib7000p_set_wbd_ref(fe, offset + dib0070_wbd_offset(fe));<br>v4l/dib0700_devices.c:&nbsp; deb_info(&quot;WBD for DiB7000P: %d\n&quot;, offset + dib0070_wbd_offset(fe));
<br>v4l/dib0700_devices.c:&nbsp; dib7000p_set_wbd_ref(fe, offset + dib0070_wbd_offset(fe));<br>v4l/dib0070.c:u16 dib0070_wbd_offset(struct dvb_frontend *fe)<br>v4l/dib0070.c:EXPORT_SYMBOL(dib0070_wbd_offset);<br>v4l/dib0070.h:extern u16 dib0070_wbd_offset(struct dvb_frontend *);
<br><br><br>I did build 2 weeks ago without any problems. I run it on a Ubuntu 7.04 machine:<br>$ uname -a<br>Linux hgu 2.6.20-16-generic #2 SMP Thu Jun 7 19:00:28 UTC 2007 x86_64 GNU/Linux<br><br>Do I need to upgrade to a newer kernel, to use this latest code? Or maybe the dib0070 instead of dib0700 is a problem? I have a Hauppauge NOVA-T 500 PCI, so I use this specific module. I appreciate any help for finding the issue, as said before I&#39;m new to the v4l-dvb code and compiling kernel modules.
<br><br>&nbsp; Harald<br><br>