<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
  <meta content="text/html;charset=UTF-8" http-equiv="Content-Type">
</head>
<body bgcolor="#ffffff" text="#000000">
Abylai Ospan schreef:
<blockquote cite="mid:1188758349.4601.1514.camel@alkaloid.netup.ru"
 type="cite">
  <meta http-equiv="Content-Type" content="text/html; ">
  <meta name="GENERATOR" content="GtkHTML/3.9.92">
В Вск, 02/09/2007 в 19:53 +0200, Michel Verbraak пишет:<br>
  <blockquote type="CITE"> Abylai Ospan schreef: <br>
    <blockquote type="CITE"> Hello !<br>
      <br>
I have gentoo linux with kernel.org stock kernel 2.6.20 and I have
compiled and installed v4l source from <a moz-do-not-send="true"
 href="http://jusst.de/manu/">http://jusst.de/manu/</a><a
 moz-do-not-send="true"
 href="http://jusst.de/manu/mantis-v4l-dvb.tar.bz2">mantis-v4l-dvb.tar.bz2</a> 
dated 01-Apr-2007 17:46  4.8M.<br>
      <br>
After 'modprobe mantis' I'v see in dmesg:<br>
      <br>
ACPI: PCI Interrupt 0000:02:03.0[A] -&gt; GSI 23 (level, low) -&gt; IRQ
19<br>
irq: 19, latency: 32<br>
memory: 0xfbfff000, mmio: 0xf8826000<br>
found a VP-1034 PCI DVB-S/DSS device on (02:03.0),<br>
    Mantis Rev 1 [1822:0014], irq: 19, latency: 32<br>
    memory: 0xfbfff000, mmio: 0xf8826000<br>
    MAC Address=[00:08:ca:1a:a3:68]<br>
mantis_alloc_buffers (0): DMA=0x301f0000 cpu=0xf01f0000 size=65536<br>
mantis_alloc_buffers (0): RISC=0x377af000 cpu=0xf77af000 size=1000<br>
DVB: registering new adapter (Mantis dvb adapter).<br>
mantis_frontend_init (0): Probing for MB86A16 (DVB-S/DSS)<br>
mantis_frontend_init (0): found MB86A16 DVB-S/DSS frontend @0x08<br>
DVB: registering frontend 0 (Fujitsu MB86A16 DVB-S)...<br>
      <br>
and /dev/dvb/adapter0/ tree is created. It's looks like card correctly
detected.<br>
But I don't see /dev/dvb/adapter0/ca0 for CI module. Is this driver
supports Twinhan 1034 CI interface ?<br>
May be some repository with newer version is available ?<br>
Thanks !<br>
      <br>
      <table cellpadding="0" cellspacing="0" width="100%">
        <tbody>
          <tr>
            <td>
-- <br>
Abylai Ospan &lt;<a moz-do-not-send="true" href="mailto:aospan@netup.ru">aospan@netup.ru</a>&gt;<br>
NetUP Inc. </td>
          </tr>
        </tbody>
      </table>
      <pre>
<hr length="90%" size="4">


_______________________________________________
linux-dvb mailing list
<a moz-do-not-send="true" href="mailto:linux-dvb@linuxtv.org">linux-dvb@linuxtv.org</a>
<a moz-do-not-send="true"
 href="http://www.linuxtv.org/cgi-bin/mailman/listinfo/linux-dvb">http://www.linuxtv.org/cgi-bin/mailman/listinfo/linux-dvb</a>
      </pre>
    </blockquote>
Currently not in the supplied open source drivers. There is a binary
package at the Twinhan (download page) website which does support the
CI but the modules were compiled for the first Fedore Core 6 kernel on
a i586 platform.<br>
  </blockquote>
Ok, thanks. But this module can't loading under linux kernel 2.6.20 (as
expected):<br>
insmod: error inserting 'linuxdriver/v4l/mantis.ko': -1 Invalid module
format<br>
mantis: version magic '2.6.18-1.2798.fc6 SMP mod_unload 686 REGPARM
4KSTACKS gcc-4.1' should be '2.6.20 SMP mod_unload PENTIUM4 '<br>
  <br>
Do you know how to "force" load this module ? May be some way to change
"magic" string for matching ? I don't want to install FC6 ... :)<br>
Thanks!<br>
  <br>
  <table cellpadding="0" cellspacing="0" width="100%">
    <tbody>
      <tr>
        <td>
-- <br>
Abylai Ospan &lt;<a moz-do-not-send="true" href="mailto:aospan@netup.ru">aospan@netup.ru</a>&gt;<br>
NetUP Inc.
        </td>
      </tr>
    </tbody>
  </table>
</blockquote>
You could try a 'modprobe --force mantis'. But hte other modules neede
should be that of the binary package and should also be loade with the
--force option.<br>
<br>
Regards,<br>
<br>
Michel.<br>
</body>
</html>