<br><br><div><span class="gmail_quote">2007/9/17, Luca Olivetti &lt;<a href="mailto:luca@ventoso.org" target="_blank" onclick="return top.js.OpenExtLink(window,event,this)">luca@ventoso.org</a>&gt;:</span><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">

En/na Moisés Pérez ha escrit:<br><br>[again, I ask you to keep the discussion on the mailing list ]</blockquote><div><br>Sorry, but&nbsp; gmail have sent the mail automatically to your personal mail, I realized now....sorry!! (my first mail list)
<br>
</div><br><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">&gt;<br>&gt; I&#39;ve tried configure lirc with af9005-remote and with af9005-lirc, but
<br>&gt; when i try run irrecord, it says that lirc is not configured. In<br>&gt; /etc/lirc/hardware.conf, i don&#39;t know what driver must been used.<br><br>below you say that you have an error loading dvb-usb-af9005-lirc.ko

, so<br>that&#39;s not suprising: if the module doesn&#39;t load it&#39;s not going to work<br>[...]</blockquote><div><br>Yes, below is explained<br></div><br><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
&gt;&nbsp;&nbsp;Seen that I can&#39;t configure lirc with af9005-lirc module and<br>&gt; af9005-remote doesn&#39;t work, I&#39;ve tried to get the IR string but nothing
<br>&gt; happens.<br>&gt;<br>&gt;&nbsp;&nbsp;I&#39;ve probed with af9005-remote and af9005-lirc (I know that would use<br>&gt; the first one) including the debug=1 option in module charging.<br>&gt;<br>&gt;&nbsp;&nbsp;&nbsp;&nbsp; sudo rmmod -f dvb_usb_af9005_remote
<br>&gt;&nbsp;&nbsp;&nbsp;&nbsp; sudo modprobe dvb_usb_af9005_remote debug=1<br>&gt;<br>&gt;&nbsp;&nbsp;Nothing appears on syslog pressing keys.<br><br>so either your modprobe is ignoring command line switches (it happened<br>to me), or you didn&#39;t enable debug while compiling the modules (if you
<br>use the mercurial tree I think it&#39;s enabled by default), or your syslog<br>daemon is sending messages somewhere else. <br></blockquote><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
&gt;<br>&gt;&nbsp;&nbsp;&nbsp;&nbsp; With af9005-lirc, charging it as here is explained<br>&gt; &lt;<a href="http://www.linuxtv.org/pipermail/linux-dvb/2007-January/015612.html" target="_blank" onclick="return top.js.OpenExtLink(window,event,this)">

http://www.linuxtv.org/pipermail/linux-dvb/2007-January/015612.html</a>&gt;,I&#39;ve<br>&gt; gotten an error, I report it:<br>&gt;<br>&gt; $-sudo modprobe dvb-usb-af9005-lirc debug=1 &gt; raw_code_log<br>&gt; FATAL: Error inserting dvb_usb_af9005_lirc
<br>&gt; (/lib/modules/2.6.20-16-generic/kernel/drivers/media/dvb/dvb-usb/dvb-usb-af9005-lirc.ko):<br>&gt; Unknown symbol in module, or unknown parameter (see dmesg)<br><br>Well, see dmesg to see what&#39;s the missing symbol. BTW, the redirection
<br>here does nothing (or maybe that&#39;s the cause for the error).</blockquote><div><br>I&#39;ve tried to load the af9005-lirc module with the device unplugged (to see the debug) and it doesn&#39;t work, the error is the same
<br><br>$ sudo modprobe dvb-usb-af9005-lirc debug=1<br>FATAL: Error inserting dvb_usb_af9005_lirc (/lib/modules/2.6.20-16-generic/kernel/drivers/media/dvb/dvb-usb/dvb-usb-af9005-lirc.ko): Unknown symbol in module, or unknown parameter (see dmesg)
<br><br>&nbsp;$dmesg:<br>[ 2953.248000] dvb_usb_af9005_lirc: Unknown symbol lirc_unregister_plugin<br>[ 2953.248000] dvb_usb_af9005_lirc: Unknown symbol lirc_register_plugin<br><br>My kernel version is 2.6.20-16-generic installed by apt-get from ubuntu repository.
<br>Lirc version is lirc-0.8.2, installed by apt-get too.<br>Should it work if I compile lirc instead of using pre-compiled packages?¿<br></div><br><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
&gt;&nbsp;&nbsp;Thank you very much for your help!!<br>&gt;&nbsp;&nbsp;I thing that my remote is different of yours and it doesn&#39;t<br>&gt; work....neither with af9005-remote or with af9005-lirc (because I can&#39;t
<br>&gt; [don&#39;t know how] configure it.<br><br><br>with the dvb-usb-af9005-lirc module it should work with any remote, it&#39;s<br>only (much) more convoluted to setup.</blockquote><div><br>I see it!! But my remote (
<a href="http://img85.imageshack.us/my.php?image=p9160087cp0.jpg">see it on link</a>) doesn&#39;t work correctly with the af9005-remote driver provided by linux-dvb sources. It creates a input device that I can&#39;t get any input from it, or directly doesn&#39;t appear the just created devide on my /dev/input.
<br><br>Thanks for your help and sorry for not keeping the discussion on the list (I haven&#39;t realized)...sorry to all!!<br></div><br><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
Bye<br>--<br>Luca<br><br><br>_______________________________________________
<br>linux-dvb mailing list<br><a href="mailto:linux-dvb@linuxtv.org" target="_blank" onclick="return top.js.OpenExtLink(window,event,this)">linux-dvb@linuxtv.org</a><br><a href="http://www.linuxtv.org/cgi-bin/mailman/listinfo/linux-dvb" target="_blank" onclick="return top.js.OpenExtLink(window,event,this)">
http://www.linuxtv.org/cgi-bin/mailman/listinfo/linux-dvb
</a><br></blockquote></div>