Hi,<br><br>I assume that itīs me you mention.<br>I have my htpc running with a nova-TD and itīs working ok with the exception of SVT1 which for some reasons occasionaly generates disconnects as seen on the Nova-T 500. To note here is that I have a VIA usb card, using my onboard nvidia USB led to hard hangs within ~4 hours with the nova-TD.
<br><br>Reception is a tad better with the nova-T 500 (which also chokes on SVT1).<br>Contact me if you need more detailed information about my kernel .....<br><br>/Henrik<br><br><br><div class="gmail_quote">On Dec 16, 2007 5:07 PM, Tomas &lt;
<a href="mailto:psycho@pobox.com">psycho@pobox.com</a>&gt; wrote:<br><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">Hello,<br><br>I&#39;m having problems tuning my Hauppauge WinTV Nova-TD USB DVB
<br>receiver.<br><br>Scanning for channels works fine with the &#39;scan&#39; utility, I have<br>compared the result with the result from a scan performed using<br>my Twinhan DTV Alpha USB stick (7045, not 7045A, which is another
<br>story...) and they are identical.<br><br>But when it&#39;s time to record, using the same program I use with<br>the Twinhan stick, I get (almost) no output, just a ridiculously<br>high bit error rate (2097151) and SNR=0. I&#39;m very surprised by
<br>this, as the channel scanning works just fine.<br><br>As far as I understand, and as previously reported by Henrik<br>Backman, the Nova-TD should work with the DVB-T broadcasts here<br>in Sweden.<br><br>Could my problems be caused by the important bug mentioned
<br>yesterday by Patrick Boettcher? If so, is there an earlier<br>version of the driver which doesn&#39;t have this bug?<br><br>The command used to test recording:<br><br>~# /usr/local/bin/dvbstream -f 490000 -p V -s 27500 -c 0 -o:
test.ts 1029 1028<br>dvbstream v0.6 - (C) Dave Chapman 2001-2004<br>Released under the GPL.<br>Latest version available from <a href="http://www.linuxstb.org/" target="_blank">http://www.linuxstb.org/</a><br>Processing -o:
test.ts<br>Open file test.ts<br>Using DVB card &quot;DiBcom 7000PC&quot;<br>tuning DVB-T (Stockholm Nacka) to 490000000 Hz, Bandwidth: 8<br>polling....<br>Getting frontend event<br>FE_STATUS:<br>polling....<br>Getting frontend event
<br>FE_STATUS: FE_HAS_SIGNAL FE_HAS_LOCK FE_HAS_CARRIER FE_HAS_SYNC<br>Event: &nbsp;Frequency: 490000000<br>Bit error rate: 2097151<br>Signal strength: 65535<br>SNR: 0<br>FE_STATUS: FE_HAS_SIGNAL FE_HAS_LOCK FE_HAS_CARRIER FE_HAS_SYNC
<br>MAP 0, file test.ts: From -1 secs, To -1 secs, 2 PIDs - &nbsp;1029 1028<br>dvbstream will stop after -1 seconds (71582788 minutes)<br>Setting filter for PID 1029<br>Setting filter for PID 1028<br>Using <a href="http://224.0.1.2:5004" target="_blank">
224.0.1.2:5004</a>:2<br>version=2<br>Streaming 2 streams<br>Caught signal 2 - closing cleanly.<br>~# ls -la test.ts<br>-rw-r--r-- 1 ath ath 188 Dec 16 16:43 test.ts<br>~#<br><br>(I&#39;m terminating the program by pressing Ctrl-C). Whether I get
<br>any packets at all seems totally random. In this attempt I got<br>one single packet from several minutes of running dvbstream!<br><br>A sample from the scan output:<br><br>~# grep &#39;^SVT2:&#39; .dvb_channels<br>SVT2:490000000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_2_3:FEC_1_2:QAM_64:TRANSMISSION_MODE_8K:GUARD_INTERVAL_1_8:HIERARCHY_NONE:1029:1028:5060
<br>~#<br><br>I have also tried tuning with tzap and recording using cat, but<br>tzap gives this:<br><br>~# tzap -a 0 -c ~/.dvb_channels &#39;SVT2&#39;<br>using &#39;/dev/dvb/adapter0/frontend0&#39; and<br>&#39;/dev/dvb/adapter0/demux0&#39;
<br>tuning to 490000000 Hz<br>video pid 0x0405, audio pid 0x0404<br>status 0f | signal b496 | snr 0000 | ber 001fffff | unc 00000000 |<br>status 1e | signal ffff | snr 0000 | ber 00000000 | unc 00000000 | FE_HAS_LOCK<br>status 1e | signal ffff | snr 0000 | ber 00000000 | unc 00000000 | FE_HAS_LOCK
<br>...<br><br>~# tzap -a 1 -c ~/.dvb_channels &#39;SVT2&#39;<br>using &#39;/dev/dvb/adapter1/frontend0&#39; and<br>&#39;/dev/dvb/adapter1/demux0&#39;<br>tuning to 490000000 Hz<br>video pid 0x0405, audio pid 0x0404<br>status 1a | signal ffff | snr 0000 | ber 001fffff | unc 00000000 | FE_HAS_LOCK
<br>status 1a | signal ffff | snr 0000 | ber 001fffff | unc 00000000 | FE_HAS_LOCK<br>status 1a | signal ffff | snr 0000 | ber 001fffff | unc 00000000 | FE_HAS_LOCK<br>...<br><br>And the &#39;cat&#39; command gives just as little TS data as dvbstream
<br>does.<br><br>I&#39;m using Linux kernel <a href="http://2.6.22.6" target="_blank">2.6.22.6</a>, and updated the dvb drivers from<br>the hg sources about two hours ago. Relevant dmesg output:<br><br>[ 1293.235000] usb 1-2: new high speed USB device using ehci_hcd and address 2
<br>[ 1293.350000] usb 1-2: configuration #1 chosen from 1 choice<br>[ 1293.432000] dib0700: loaded with support for 5 different device-types<br>[ 1293.440000] dvb-usb: found a &#39;Hauppauge Nova-TD Stick/Elgato Eye-TV Diversity&#39; in cold state, will try to load a firmware
<br>[ 1293.858000] dvb-usb: downloading firmware from file &#39;dvb-usb-dib0700-1.10.fw&#39;<br>[ 1294.146000] dib0700: firmware started successfully.<br>[ 1294.648000] dvb-usb: found a &#39;Hauppauge Nova-TD Stick/Elgato Eye-TV Diversity&#39; in warm state.
<br>[ 1294.649000] dvb-usb: will pass the complete MPEG2 transport stream to the software demuxer.<br>[ 1294.649000] DVB: registering new adapter (Hauppauge Nova-TD Stick/Elgato Eye-TV Diversity)<br>[ 1294.875000] DVB: registering frontend 0 (DiBcom 7000PC)...
<br>[ 1294.907000] MT2266: successfully identified<br>[ 1295.060000] dvb-usb: will pass the complete MPEG2 transport stream to the software demuxer.<br>[ 1295.061000] DVB: registering new adapter (Hauppauge Nova-TD Stick/Elgato Eye-TV Diversity)
<br>[ 1295.223000] DVB: registering frontend 1 (DiBcom 7000PC)...<br>[ 1295.228000] MT2266: successfully identified<br>[ 1295.382000] input: IR-receiver inside an USB DVB receiver as /class/input/input7<br>[ 1295.382000] dvb-usb: schedule remote query interval to 150 msecs.
<br>[ 1295.383000] dvb-usb: Hauppauge Nova-TD Stick/Elgato Eye-TV Diversity successfully initialized and connected.<br>[ 1295.383000] usbcore: registered new interface driver dvb_usb_dib0700<br><br>The firmware is a renamed 
dvb-usb-dib0700-03-pre1.fw :<br><br>~# ls -la /lib/firmware/dvb*<br>-rw-r--r-- 1 root root 33277 2007-12-04 15:51 /lib/firmware/dvb-usb-dib0700-03-pre1.fw<br>-rw-r--r-- 1 root root 33277 2007-12-04 15:51 /lib/firmware/dvb-
usb-dib0700-1.10.fw<br>~# cmp /lib/firmware/dvb-usb-dib0700-*<br>~#<br><br>I&#39;ve just spent over an hour fighting with mythtv configuration<br>(I installed the Debian packages) and would appreciate<br>suggestions that do not involve mythtv, as I can&#39;t get the thing
<br>working.<br><br>/Tomas<br><br>_______________________________________________<br>linux-dvb mailing list<br><a href="mailto:linux-dvb@linuxtv.org">linux-dvb@linuxtv.org</a><br><a href="http://www.linuxtv.org/cgi-bin/mailman/listinfo/linux-dvb" target="_blank">
http://www.linuxtv.org/cgi-bin/mailman/listinfo/linux-dvb</a><br></blockquote></div><br>