<html xmlns:v="urn:schemas-microsoft-com:vml" xmlns:o="urn:schemas-microsoft-com:office:office" xmlns:w="urn:schemas-microsoft-com:office:word" xmlns:m="http://schemas.microsoft.com/office/2004/12/omml" xmlns="http://www.w3.org/TR/REC-html40">

<head>
<meta http-equiv=Content-Type content="text/html; charset=us-ascii">
<meta name=Generator content="Microsoft Word 12 (filtered medium)">
<style>
<!--
 /* Font Definitions */
 @font-face
        {font-family:"Cambria Math";
        panose-1:2 4 5 3 5 4 6 3 2 4;}
@font-face
        {font-family:Calibri;
        panose-1:2 15 5 2 2 2 4 3 2 4;}
 /* Style Definitions */
 p.MsoNormal, li.MsoNormal, div.MsoNormal
        {margin:0cm;
        margin-bottom:.0001pt;
        font-size:11.0pt;
        font-family:"Calibri","sans-serif";}
a:link, span.MsoHyperlink
        {mso-style-priority:99;
        color:blue;
        text-decoration:underline;}
a:visited, span.MsoHyperlinkFollowed
        {mso-style-priority:99;
        color:purple;
        text-decoration:underline;}
span.EmailStyle17
        {mso-style-type:personal-compose;
        font-family:"Calibri","sans-serif";
        color:windowtext;}
.MsoChpDefault
        {mso-style-type:export-only;}
@page Section1
        {size:612.0pt 792.0pt;
        margin:72.0pt 72.0pt 72.0pt 72.0pt;}
div.Section1
        {page:Section1;}
-->
</style>
<!--[if gte mso 9]><xml>
 <o:shapedefaults v:ext="edit" spidmax="1026" />
</xml><![endif]--><!--[if gte mso 9]><xml>
 <o:shapelayout v:ext="edit">
  <o:idmap v:ext="edit" data="1" />
 </o:shapelayout></xml><![endif]-->
</head>

<body lang=EN-GB link=blue vlink=purple>

<div class=Section1>

<p class=MsoNormal>Hi everybody,<o:p></o:p></p>

<p class=MsoNormal><o:p>&nbsp;</o:p></p>

<p class=MsoNormal>I&#8217;m getting closer to a working driver, but I&#8217;m
not there yet. The errors are getting stranger though :-)<o:p></o:p></p>

<p class=MsoNormal>First of all, when I make my module, I&#8217;m getting the
following warnings:<o:p></o:p></p>

<p class=MsoNormal><o:p>&nbsp;</o:p></p>

<p class=MsoNormal>WARNING: &quot;ieee1394_bus_type&quot; [/file-location/driver.ko]
undefined!<o:p></o:p></p>

<p class=MsoNormal>WARNING: &quot;hpsb_send_packet_and_wait&quot; [/file-location/driver.ko]
undefined!<o:p></o:p></p>

<p class=MsoNormal>WARNING: &quot;dvb_usercopy&quot; [/file-location/driver.ko]
undefined!<o:p></o:p></p>

<p class=MsoNormal><o:p>&nbsp;</o:p></p>

<p class=MsoNormal>Just warnings, no errors.<o:p></o:p></p>

<p class=MsoNormal>Now, when I try to insmod driver.ko, I&#8217;m getting the
following errors in dmesg:<o:p></o:p></p>

<p class=MsoNormal><o:p>&nbsp;</o:p></p>

<p class=MsoNormal>driver: Unknown symbol dvb_usercopy<o:p></o:p></p>

<p class=MsoNormal>driver: Unknown symbol hpsb_send_packet_and_wait<o:p></o:p></p>

<p class=MsoNormal>driver: Unknown symbol ieee1394_bus_type<o:p></o:p></p>

<p class=MsoNormal>driver: disagrees about version of symbol
dvb_unregister_frontend<o:p></o:p></p>

<p class=MsoNormal>driver: Unknown symbol dvb_unregister_frontend<o:p></o:p></p>

<p class=MsoNormal>driver: disagrees about version of symbol
dvb_register_frontend<o:p></o:p></p>

<p class=MsoNormal>driver: Unknown symbol dvb_register_frontend<o:p></o:p></p>

<p class=MsoNormal><o:p></o:p></p>

<p class=MsoNormal>The first 3 errors are to be expected when you see the
warnings in the make-process, the last 4 are new.<o:p></o:p></p>

<p class=MsoNormal>But I don&#8217;t get why I get those errors... When I look
in /proc/kallsyms, those functions exist:<o:p></o:p></p>

<p class=MsoNormal><o:p>&nbsp;</o:p></p>

<p class=MsoNormal>$ cat /proc/kallsyms | grep dvb_usercopy<o:p></o:p></p>

<p class=MsoNormal>f8de4080 t dvb_usercopy [dvb_core]<o:p></o:p></p>

<p class=MsoNormal>$ cat /proc/kallsyms | grep ieee1394_bus_type<o:p></o:p></p>

<p class=MsoNormal>f88eb420 d ieee1394_bus_type&nbsp;&nbsp;&nbsp; [ieee1394]<o:p></o:p></p>

<p class=MsoNormal>$ cat /proc/kallsyms | grep hpsb_send_packet_and_wait<o:p></o:p></p>

<p class=MsoNormal>f88d6600 t hpsb_send_packet_and_wait&nbsp;&nbsp;&nbsp;
[ieee1394]<o:p></o:p></p>

<p class=MsoNormal><o:p>&nbsp;</o:p></p>

<p class=MsoNormal>$ cat /proc/kallsyms | grep dvb_unregister_frontend<o:p></o:p></p>

<p class=MsoNormal>f8df0814 r
__ksymtab_dvb_unregister_frontend&nbsp;&nbsp;&nbsp; [dvb_core]<o:p></o:p></p>

<p class=MsoNormal>f8df0bdc r
__kstrtab_dvb_unregister_frontend&nbsp;&nbsp;&nbsp; [dvb_core]<o:p></o:p></p>

<p class=MsoNormal>f8df08f0 r
__kcrctab_dvb_unregister_frontend&nbsp;&nbsp;&nbsp; [dvb_core]<o:p></o:p></p>

<p class=MsoNormal>f8dea540 T
dvb_unregister_frontend&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; [dvb_core]<o:p></o:p></p>

<p class=MsoNormal>6bc0e425 a
__crc_dvb_unregister_frontend&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
[dvb_core]<o:p></o:p></p>

<p class=MsoNormal><o:p>&nbsp;</o:p></p>

<p class=MsoNormal>$ cat /proc/kallsyms | grep dvb_register_frontend<o:p></o:p></p>

<p class=MsoNormal>f8df081c r
__ksymtab_dvb_register_frontend&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; [dvb_core]<o:p></o:p></p>

<p class=MsoNormal>f8df0bf4 r
__kstrtab_dvb_register_frontend&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; [dvb_core]<o:p></o:p></p>

<p class=MsoNormal>f8df08f4 r __kcrctab_dvb_register_frontend&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
[dvb_core]<o:p></o:p></p>

<p class=MsoNormal>1f556d1c a __crc_dvb_register_frontend&nbsp; [dvb_core]<o:p></o:p></p>

<p class=MsoNormal>f8dead60 T
dvb_register_frontend&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; [dvb_core]<o:p></o:p></p>

<p class=MsoNormal><o:p></o:p></p>

<p class=MsoNormal><o:p>&nbsp;</o:p></p>

<p class=MsoNormal>I hope there&#8217;s someone who can help me out, because I
don&#8217;t know what I&#8217;m doing wrong :-(<o:p></o:p></p>

<p class=MsoNormal><o:p>&nbsp;</o:p></p>

<p class=MsoNormal><o:p>&nbsp;</o:p></p>

<p class=MsoNormal>Greetings (and happy holidays),<o:p></o:p></p>

<p class=MsoNormal>Ben<o:p></o:p></p>

</div>

</body>

</html>