<html><head><style type="text/css"><!-- DIV {margin:0px;} --></style></head><body><div style="font-family:verdana,helvetica,sans-serif;font-size:10pt"><div>I installed two items in my machine recently <br>1) Hauppage hvr950<br>2) Hauppage pvr 1800<br><br><span>To get them to work, I built and installed from <a target="_blank" href="http://linuxtv.org/hg/v4l-dvb">http://linuxtv.org/hg/v4l-dvb</a>.</span>&nbsp; The compile and install went well, but I get the following in /var/log/messages:<br><br>xc2028 2-0061: Error: firmware xc3028-v27.fw not found<br><br>Is that for the 1800 card?&nbsp;&nbsp; I haven't been able to find that firmware.&nbsp; Would that be extracted from the driver CD?&nbsp; I might have tossed it out...<br>
<br>I do have the following /dev/dvb/adapter0 entries: <br><br>crw-rw----+ 1 mythtv root 212, 4 2007-12-28 20:15 demux0<br>crw-rw----+ 1 mythtv root 212, 5 2007-12-28 20:15 dvr0<br>crw-rw----+ 1 mythtv root 212, 3 2007-12-28 20:15 frontend0<br>crw-rw----+ 1 mythtv root 212, 7 2007-12-28 20:15 net0<br><br>Which tuner does /dev/dvb/adapter0 represent?<br><br>I also have a new entry at /dev/video1 (/dev/video0 is my old pvr 150 card).&nbsp; I want to tell mythtv to use that tuner but I'm not sure what type it is.&nbsp; Is it an analog V4L tuner?&nbsp; <br><br>This is the relevant part of dmesg:<br><br>i2c-adapter i2c-0: nForce2 SMBus adapter at 0x1c00<br>i2c-adapter i2c-1: nForce2 SMBus adapter at 0x1c40<br>lirc_dev: IR Remote Control driver registered, major 61 <br>lirc_streamzap[-1]: Streamzap, Inc. Streamzap Remote Control on usb2:2 attached<br>lirc_dev: lirc_register_plugin: sample_rate: 0<br>usbcore: registered new interface driver
 lirc_streamzap<br>lirc_streamzap $Revision: 1.22 $ registered<br>input: Power Button (FF) as /class/input/input5<br>ACPI: Power Button (FF) [PWRF]<br>input: Power Button (CM) as /class/input/input6<br>ACPI: Power Button (CM) [PWRB]<br>Linux video capture interface: v2.00<br>input: PC Speaker as /class/input/input7<br>forcedeth.c: Reverse Engineered nForce ethernet driver. Version 0.60.<br>ACPI: PCI Interrupt Link [APCH] enabled at IRQ 23<br>ACPI: PCI Interrupt 0000:00:14.0[A] -&gt; Link [APCH] -&gt; GSI 23 (level, low) -&gt; IRQ 23<br>PCI: Setting latency timer of device 0000:00:14.0 to 64<br>forcedeth: using HIGHDMA<br>em28xx v4l2 driver version 0.1.0 loaded<br>em28xx new video device (2040:6513): interface 0, class 255<br>em28xx #0: Alternate settings: 8<br>em28xx #0: Alternate setting 0, max size= 0<br>em28xx #0: Alternate setting 1, max size= 0<br>em28xx #0: Alternate setting 2, max size= 1448<br>em28xx #0: Alternate setting 3, max size=
 2048<br>em28xx #0: Alternate setting 4, max size= 2304<br>em28xx #0: Alternate setting 5, max size= 2580<br>em28xx #0: Alternate setting 6, max size= 2892<br>em28xx #0: Alternate setting 7, max size= 3072<br>nvidia: module license 'NVIDIA' taints kernel.<br>ivtv:&nbsp; Start initialization, version 1.2.0<br>cx23885 driver version 0.0.1 loaded<br>em28xx #0: i2c eeprom 00: 1a eb 67 95 40 20 13 65 d0 12 5c 03 82 1e 6a 18<br>em28xx #0: i2c eeprom 10: 00 00 24 57 66 07 01 00 00 00 00 00 00 00 00 00<br>em28xx #0: i2c eeprom 20: 46 00 01 00 f0 10 02 00 b8 00 00 00 5b 1c 00 00<br>em28xx #0: i2c eeprom 30: 00 00 20 40 20 80 02 20 01 01 01 01 00 00 00 00<br>em28xx #0: i2c eeprom 40: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00<br>em28xx #0: i2c eeprom 50: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00<br>em28xx #0: i2c eeprom 60: 00 00 00 00 00 00 00 00 00 00 18 03 34 00 30 00<br>em28xx #0: i2c eeprom 70: 32 00 38 00 34 00 34 00 36 00 32 00 35 00 37
 00<br>em28xx #0: i2c eeprom 80: 00 00 1e 03 57 00 69 00 6e 00 54 00 56 00 20 00<br>em28xx #0: i2c eeprom 90: 48 00 56 00 52 00 2d 00 39 00 38 00 30 00 00 00<br>em28xx #0: i2c eeprom a0: 84 12 00 00 05 50 1a 7f d4 78 23 b1 fe d0 18 85<br>em28xx #0: i2c eeprom b0: 1f 00 00 00 04 84 0a 00 01 01 20 77 00 40 31 36<br>em28xx #0: i2c eeprom c0: 1d f0 74 02 01 00 01 79 02 00 00 00 00 00 00 00<br>em28xx #0: i2c eeprom d0: 84 12 00 00 05 50 1a 7f d4 78 23 b1 fe d0 18 85<br>em28xx #0: i2c eeprom e0: 1f 00 00 00 04 84 0a 00 01 01 20 77 00 40 31 36<br>em28xx #0: i2c eeprom f0: 1d f0 74 02 01 00 01 79 02 00 00 00 00 00 00 00<br>EEPROM ID= 0x9567eb1a, hash = 0x67ef26dd<br>Vendor/Product ID= 2040:6513<br>AC97 audio (5 sample rates)<br>500mA max power<br>Table at 0x24, strings=0x1e82, 0x186a, 0x0000<br>tveeprom 2-0050: Hauppauge model 65201, rev A1C0, serial# 1914417<br>tveeprom 2-0050: tuner model is Xceive XC3028 (idx 120, type 71)<br>tveeprom 2-0050: TV standards
 PAL(B/G) PAL(I) PAL(D/D1/K) ATSC/DVB Digital (eeprom 0xd4)<br>tveeprom 2-0050: audio processor is None (idx 0)<br>tveeprom 2-0050: has radio<br>eth0: forcedeth.c: subsystem: 010de:cb84 bound to 0000:00:14.0<br>ACPI: PCI Interrupt Link [APC4] enabled at IRQ 19<br>ACPI: PCI Interrupt 0000:04:07.0[A] -&gt; Link [APC4] -&gt; GSI 19 (level, low) -&gt; IRQ 19<br>PCI: Setting latency timer of device 0000:04:07.0 to 64<br>ACPI: PCI Interrupt Link [APC7] enabled at IRQ 16<br>ACPI: PCI Interrupt 0000:00:05.0[A] -&gt; Link [APC7] -&gt; GSI 16 (level, low) -&gt; IRQ 16<br>PCI: Setting latency timer of device 0000:00:05.0 to 64<br>firewire_ohci: Added fw-ohci device 0000:04:07.0, OHCI version 1.10<br>ACPI: PCI Interrupt Link [APC5] enabled at IRQ 16<br>ACPI: PCI Interrupt 0000:03:00.0[A] -&gt; Link [APC5] -&gt; GSI 16 (level, low) -&gt; IRQ 16<br>CORE cx23885[0]: subsystem: 0070:7801, board: Hauppauge WinTV-HVR1800 [card=2,autodetected]<br>cx23885[0]: i2c bus 0
 registered<br>cx23885[0]: i2c bus 1 registered<br>cx23885[0]: i2c bus 2 registered<br>tveeprom 3-0050: Hauppauge model 78521, rev C1E9, serial# 2581147<br>tveeprom 3-0050: MAC address is 00-0D-FE-27-62-9B<br>tveeprom 3-0050: tuner model is Philips 18271_8295 (idx 149, type 54)<br>tveeprom 3-0050: TV standards NTSC(M) ATSC/DVB Digital (eeprom 0x88)<br>tveeprom 3-0050: audio processor is CX23887 (idx 42)<br>tveeprom 3-0050: decoder processor is CX23887 (idx 37)<br>tveeprom 3-0050: has radio, has no IR receiver, has no IR transmitter<br>cx23885[0]: hauppauge eeprom: model=78521<br>cx23885[0]: cx23885 based dvb card<br>tuner' 2-0061: chip found @ 0xc2 (em28xx #0)<br>xc2028 2-0061: type set to XCeive xc2028/xc3028 tuner<br>xc2028 2-0061: xc2028/3028 firmware name not set!<br>xc2028 2-0061: Error: firmware xc3028-v27.fw not found.<br>MT2131: successfully identified at address 0x61<br>DVB: registering new adapter (cx23885[0])<br>DVB: registering frontend 0
 (Samsung S5H1409 QAM/8VSB Frontend)...<br>cx23885[0]/0: found at 0000:03:00.0, rev: 15, irq: 16, latency: 0, mmio: 0xfd600000<br>PCI: Setting latency timer of device 0000:03:00.0 to 64<br>ivtv0: Initializing card #0<br>ivtv0: Autodetected Hauppauge card (cx23416 based)<br>ACPI: PCI Interrupt Link [APC3] enabled at IRQ 18<br>ACPI: PCI Interrupt 0000:04:0a.0[A] -&gt; Link [APC3] -&gt; GSI 18 (level, low) -&gt; IRQ 18<br>tvp5150 2-005c: tvp5150am1 detected.<br>tveeprom 6-0050: Hauppauge model 26592, rev B282, serial# 7275840<br>tveeprom 6-0050: tuner model is LG TAPC H791F (idx 82, type 39)<br>tveeprom 6-0050: TV standards NTSC(M) (eeprom 0x08)<br>tveeprom 6-0050: audio processor is CX25843 (idx 37)<br>tveeprom 6-0050: decoder processor is CX25843 (idx 30)<br>tveeprom 6-0050: has no radio, has no IR receiver, has no IR transmitter<br>ivtv0: Autodetected Hauppauge WinTV PVR-150<br>firewire_core: created new fw device fw0 (0 config rom retries,
 S400)<br>cx25840 6-0044: cx25841-23 found @ 0x88 (ivtv i2c driver #0)<br>tuner 6-0061: chip found @ 0xc2 (ivtv i2c driver #0)<br>wm8775 6-001b: chip found @ 0x36 (ivtv i2c driver #0)<br>tuner-simple 6-0061: type set to 39 (LG NTSC (newer TAPC series))<br>ivtv0: Registered device video0 for encoder MPG (16384 kB)<br>ivtv0: Registered device video32 for encoder YUV (2048 kB)<br>ivtv0: Registered device vbi0 for encoder VBI (16384 kB)<br>ivtv0: Registered device video24 for encoder PCM (320 kB)<br>ivtv0: Initialized card #0: Hauppauge WinTV PVR-150<br>ivtv:&nbsp; End initialization<br>ACPI: PCI Interrupt Link [APCJ] enabled at IRQ 22<br>ACPI: PCI Interrupt 0000:00:10.2[C] -&gt; Link [APCJ] -&gt; GSI 22 (level, low) -&gt; IRQ 22<br>PCI: Setting latency timer of device 0000:00:10.2 to 64<br>em28xx #0: V4L2 device registered as /dev/video1 and /dev/vbi1<br>em28xx #0: Found Hauppauge WinTV HVR 950<br>usbcore: registered new interface driver em28xx<br>usbcore:
 registered new interface driver snd-usb-audio<br>intel8x0_measure_ac97_clock: measured 50457 usecs<br>intel8x0: clocking to 46876<br>NVRM: loading NVIDIA UNIX x86_64 Kernel Module&nbsp; 100.14.19&nbsp; Wed Sep 12 14:08:38 PDT 2007<br>device-mapper: ioctl: 4.11.0-ioctl (2006-10-12) initialised: dm-devel@redhat.com<br>device-mapper: multipath: version 1.0.5 loaded<br>EXT3 FS on sdb7, internal journal<br>kjournald starting.&nbsp; Commit interval 5 seconds<br>EXT3 FS on sdb1, internal journal<br>EXT3-fs: mounted filesystem with ordered data mode.<br>kjournald starting.&nbsp; Commit interval 5 seconds<br>EXT3 FS on dm-0, internal journal<br>EXT3-fs: mounted filesystem with ordered data mode.<br>Adding 1959920k swap on /dev/sdb2.&nbsp; Priority:-1 extents:1 across:1959920k<br>NET: Registered protocol family 10<br>lo: Disabled Privacy Extensions<br>audit(1198901717.704:3): audit_pid=2189 old=0 by auid=4294967295<br>Installing knfsd (copyright (C) 1996
 okir@monad.swb.de).<br>NFSD: Using /var/lib/nfs/v4recovery as the NFSv4 state recovery directory<br>NFSD: starting 90-second grace period<br>eth0: no IPv6 routers present<br>ivtv0: Loaded v4l-cx2341x-enc.fw firmware (376836 bytes)<br>ivtv0: Encoder revision: 0x02060039<br>i2c-adapter i2c-7: SMBus Quick command not supported, can't probe for chips<br>i2c-adapter i2c-8: SMBus Quick command not supported, can't probe for chips<br>i2c-adapter i2c-9: SMBus Quick command not supported, can't probe for chips<br>cx25840 6-0044: loaded v4l-cx25840.fw firmware (16382 bytes)<br>DVB: frontend 0 frequency 863000000 out of range (54000000..858000000)<br>DVB: frontend 0 frequency 869000000 out of range (54000000..858000000)<br>DVB: frontend 0 frequency 875000000 out of range (54000000..858000000)<br>DVB: frontend 0 frequency 881000000 out of range (54000000..858000000)<br>DVB: frontend 0 frequency 887000000 out of range
 (54000000..858000000)<br><br></div></div></body></html>