<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML><HEAD>
<META http-equiv=Content-Type content="text/html; charset=iso-8859-1">
<META content="MSHTML 6.00.6000.16587" name=GENERATOR>
<STYLE></STYLE>
</HEAD>
<BODY bgColor=#ffffff>
<DIV><FONT face=Arial size=2>I've been playing with the latest <A 
href="http://dev.kewl.org/hauppauge/">http://dev.kewl.org/hauppauge/</A>&nbsp;drivers 
(Multi frontend Support) for the HVR4000 (<A 
href="http://dev.kewl.org/hauppauge/v4l-dvb-hg-mfe-latest.diff) and">http://dev.kewl.org/hauppauge/v4l-dvb-hg-mfe-latest.diff) 
and</A> they seem to work well.&nbsp; I can use either DVB-S or DVB-T (via 
mythtv and swap easily between them) (butt not use them at the same time which 
is just a limitation of the device)</FONT></DIV>
<DIV><FONT face=Arial size=2></FONT>&nbsp;</DIV>
<DIV><FONT face=Arial size=2>But a couple of problems.</FONT></DIV>
<DIV><FONT face=Arial size=2>Not many programs support the multifrontend as of 
yet. Like the biggest one Mythtv :-)</FONT></DIV>
<DIV><FONT face=Arial size=2>You have to do the below so it sees two 
cards</FONT></DIV>
<DIV><FONT face=Arial size=2></FONT>&nbsp;</DIV>
<DIV><FONT face=Arial size=2>mkdir /dev/dvb/adapter1</FONT></DIV>
<DIV><FONT face=Arial size=2>ln -s /dev/dvb/adapter1/frontend1 
/dev/dvb/adapter1/frontend0</FONT></DIV>
<DIV><FONT face=Arial size=2>ln -s /dev/dvb/adapter1/net1 
/dev/dvb/adapter1/net0</FONT></DIV>
<DIV><FONT face=Arial size=2>ln -s /dev/dvb/adapter1/dvr1 
/dev/dvb/adapter1/dvr0</FONT></DIV>
<DIV><FONT face=Arial size=2>ln -s /dev/dvb/adapter1/demux1 
/dev/dvb/adapter1/demux0</FONT></DIV>
<DIV><FONT face=Arial size=2></FONT>&nbsp;</DIV>
<DIV><FONT face=Arial size=2>Analog TV Tuning Stops working after you 1st use 
the DVB-T or DVB-S device</FONT></DIV>
<DIV><FONT face=Arial size=2></FONT>&nbsp;</DIV>
<DIV><FONT face=Arial size=2>a few i2c errors when it first boots 
up.</FONT></DIV>
<DIV><FONT face=Arial size=2></FONT>&nbsp;</DIV>
<DIV><FONT face=Arial size=2>tda9887 2-0043: i2c i/o error: rc == -121 (should 
be 4)<BR>DVB: registering new adapter (cx88[0])<BR>DVB: registering frontend 0 
(Conexant CX24116/CX24118)...<BR>DVB: registering frontend 0 (Conexant CX22702 
DVB-T)...<BR></FONT></DIV>
<DIV><FONT face=Arial size=2>it says registering frontend 0 both times, but 
thats just cosmetic and should easily be fixed</FONT></DIV>
<DIV><FONT face=Arial size=2></FONT>&nbsp;</DIV>
<DIV><FONT face=Arial size=2>dmesg</FONT></DIV>
<DIV><FONT face=Arial size=2>-------------------</FONT></DIV>
<DIV><FONT face=Arial size=2>cx88/2: cx2388x MPEG-TS Driver Manager version 
0.0.6 loaded<BR>cx88[0]: subsystem: 0070:6902, board: Hauppauge WinTV-HVR4000 
DVB-S/S2/T/Hybrid [card=59,autodetected], frontend(s): 2<BR>cx88[0]: TV tuner 
type 63, Radio tuner type -1<BR>cx88/0: cx2388x v4l2 driver version 0.0.6 
loaded<BR>cx2388x alsa driver version 0.0.6 loaded<BR>cx88[0]: i2c init: 
enabling analog demod on HVR1300/3000/4000 tuner<BR>tveeprom 2-0050: Hauppauge 
model 69009, rev B2D3, serial# 2807241<BR>tveeprom 2-0050: MAC address is 
00-0D-FE-2A-D5-C9<BR>tveeprom 2-0050: tuner model is Philips FMD1216MEX (idx 
133, type 63)<BR>tveeprom 2-0050: TV standards PAL(B/G) PAL(I) SECAM(L/L') 
PAL(D/D1/K) ATSC/DVB Digital (eeprom 0xf4)<BR>tveeprom 2-0050: audio processor 
is CX882 (idx 33)<BR>tveeprom 2-0050: decoder processor is CX882 (idx 
25)<BR>tveeprom 2-0050: has radio, has IR receiver, has no IR 
transmitter<BR>cx88[0]: hauppauge eeprom: model=69009<BR>input: cx88 IR 
(Hauppauge WinTV-HVR400 as /class/input/input3<BR>cx88[0]/2: cx2388x 8802 Driver 
Manager<BR>ACPI: PCI Interrupt Link [APC1] enabled at IRQ 16<BR>ACPI: PCI 
Interrupt 0000:04:08.2[A] -&gt; Link [APC1] -&gt; GSI 16 (level, low) -&gt; IRQ 
21<BR>cx88[0]/2: found at 0000:04:08.2, rev: 5, irq: 21, latency: 32, mmio: 
0xf8000000<BR>cx8802_probe() allocating 2 frontend(s)<BR>ACPI: PCI Interrupt 
0000:04:08.0[A] -&gt; Link [APC1] -&gt; GSI 16 (level, low) -&gt; IRQ 
21<BR>cx88[0]/0: found at 0000:04:08.0, rev: 5, irq: 21, latency: 32, mmio: 
0xfa000000<BR>cx88/2: cx2388x dvb driver version 0.0.6 loaded<BR>cx88/2: 
registering cx8802 driver, type: dvb access: shared<BR>cx88[0]/2: subsystem: 
0070:6902, board: Hauppauge WinTV-HVR4000 DVB-S/S2/T/Hybrid 
[card=59]<BR>cx88[0]/2: cx2388x based DVB/ATSC card<BR>tuner' 2-0043: chip found 
@ 0x86 (cx88[0])<BR>tda9887 2-0043: tda988[5/6/7] found<BR>tuner' 2-0061: chip 
found @ 0xc2 (cx88[0])<BR>tuner-simple 2-0061: type set to 63 (Philips FMD1216ME 
MK3 Hybrid Tuner)<BR>tuner' 2-0063: chip found @ 0xc6 (cx88[0])<BR>cx88[0]/0: 
registered device video0 [v4l2]<BR>cx88[0]/0: registered device 
vbi0<BR>cx88[0]/0: registered device radio0<BR>cx88[0]/1: CX88x/0: ALSA support 
for cx2388x boards<BR>ACPI: PCI Interrupt Link [AAZA] enabled at IRQ 22<BR>ACPI: 
PCI Interrupt 0000:00:10.1[B] -&gt; Link [AAZA] -&gt; GSI 22 (level, low) -&gt; 
IRQ 17<BR>tda9887 2-0043: i2c i/o error: rc == -121 (should be 4)<BR>DVB: 
registering new adapter (cx88[0])<BR>DVB: registering frontend 0 (Conexant 
CX24116/CX24118)...<BR>DVB: registering frontend 0 (Conexant CX22702 
DVB-T)...<BR>cx24116_firmware_ondemand: Waiting for firmware upload 
(dvb-fe-cx24116.fw)...<BR>cx24116_firmware_ondemand: Waiting for firmware 
upload(2)...<BR>cx24116_load_firmware: FW version 
1.20.79.0<BR>cx24116_firmware_ondemand: Firmware upload 
complete<BR>cx24116_firmware_ondemand: Waiting for firmware upload 
(dvb-fe-cx24116.fw)...<BR>cx24116_firmware_ondemand: Waiting for firmware 
upload(2)...<BR>cx24116_load_firmware: FW version 
1.20.79.0<BR>cx24116_firmware_ondemand: Firmware upload 
complete<BR>------------------</FONT></DIV>
<DIV><FONT face=Arial size=2></FONT>&nbsp;</DIV>
<DIV><FONT face=Arial size=2>Thanks</FONT></DIV>
<DIV><FONT face=Arial size=2>&nbsp;</DIV></FONT>
<DIV><FONT face=Arial size=2></FONT>&nbsp;</DIV></BODY></HTML>