<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
  <meta content="text/html;charset=ISO-8859-1" http-equiv="Content-Type">
</head>
<body bgcolor="#ffffff" text="#000000">
<br>
Faruk A schreef:
<blockquote
 cite="mid:854d46170805180507q33d8b71ct16547fce16603d66@mail.gmail.com"
 type="cite">
  <pre wrap=""><!---->
did you run szap with -rp ? make sure the channel you tuned to is not encrypted.

here is another ugly way of doing it.
u need dvbstream and vlc

szap -rp "BBC World"
dvbstream -o | vlc -
or with with mplayer: dvbstream -o | mplayer -
  </pre>
</blockquote>
Very strange,<br>
<br>
when I run dvbstream -o, without piping it into anything, I get a lot
of binary feedback in the console, but I just can't open it in any
program. (I tuned it using szap2, with the -rp option. I only tried
unencrypted channels, so no problem there) dvbstream always says
"streaming 0 streams" which is probably not so good.<br>
<br>
<blockquote>$ dvbstream -o | vlc -<br>
dvbstream will stop after -1 seconds (71582788 minutes)<br>
Output to stdout<br>
Streaming 0 streams<br>
VLC media player 0.8.6e Janus<br>
libdvdnav: Using dvdnav version 0.1.10 from <a class="moz-txt-link-freetext" href="http://dvd.sf.net">http://dvd.sf.net</a><br>
libdvdread: Using libdvdcss version 1.2.5 for DVD access<br>
libdvdread: Can't stat -<br>
No such file or directory<br>
libdvdnav: vm: faild to open/read the DVD<br>
libdvbpsi error (PSI decoder): TS discontinuity (received 3, expected
0) for PID 0<br>
</blockquote>
<br>
I even tried to output it to a file, but the file stays blank<br>
<br>
<blockquote>$ dvbstream -o:test.mpg<br>
Open file test.mpg<br>
  <br>
MAP 0, file test.mpg: From -1 secs, To -1 secs, 0 PIDs - <br>
dvbstream will stop after -1 seconds (71582788 minutes)<br>
Streaming 0 streams<br>
</blockquote>
<br>
And when I give mplayer a go I get this:<br>
<blockquote>$ dvbstream -o | mplayer -<br>
dvbstream will stop after -1 seconds (71582788 minutes)<br>
Output to stdout<br>
Streaming 0 streams<br>
MPlayer 1.0rc2-4.2.3 (C) 2000-2007 MPlayer Team<br>
CPU: Intel(R) Core(TM)2 CPU&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; 6600&nbsp; @ 2.40GHz (Family: 6, Model:
15, Stepping: 6)<br>
CPUflags:&nbsp; MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1<br>
Compiled with runtime CPU detection.<br>
mplayer: could not connect to socket<br>
mplayer: No such file or directory<br>
Failed to open LIRC support. You will not be able to use your remote
control.<br>
  <br>
Playing -.<br>
Reading from stdin...<br>
Cannot seek backward in linear streams!<br>
Seek failed<br>
</blockquote>
Sorry for extensively testing your patience! I, too, wish it would have
"just worked" :)<br>
<br>
Thank you,<br>
<br>
Jelle De Loecker<br>
</body>
</html>