<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
  <meta content="text/html;charset=ISO-8859-15"
 http-equiv="Content-Type">
  <title></title>
</head>
<body bgcolor="#ffffff" text="#000000">
Dominik Kuhlen schrieb:
<blockquote cite="mid:200806070018.16103.dkuhlen@gmx.net" type="cite">
  <pre wrap="">Hi,

On Friday 06 June 2008, Michael Schöller wrote:
  </pre>
  <blockquote type="cite">
    <pre wrap="">Well that worked! I was able to compile the drivers. :)

And the bad news. I wasn't able to compile dvb-apps. Or to be more 
specific I followed the instructions for patching dvb-apps to work with 
multiproto. (

<a class="moz-txt-link-freetext" href="http://www.linuxtv.org/pipermail/linux-dvb/2008-April/025222.html">http://www.linuxtv.org/pipermail/linux-dvb/2008-April/025222.html</a>)

As I understand the instructions I copied the source code of scan to the dvb-apps/util/scan directory and applied the patch on it. After a little extra change for the includes (changed them to point to the ones of multiproto). I was able to compile the hole stuff without errors. However scan always gives me an DVBFE_SET_PARAMS ioctl fail with "Invalid argument".
    </pre>
  </blockquote>
  <pre wrap=""><!---->are you sure you have unloaded all old dvb modules?
  </pre>
</blockquote>
Well I not sure with anything. Since /dev/dvb is only showing up after
compile the new modules I think so. I do not really have a clue to
verify it. I'm playing around with the trial and error system.<br>
<blockquote cite="mid:200806070018.16103.dkuhlen@gmx.net" type="cite">
  <pre wrap="">
  </pre>
  <blockquote type="cite">
    <pre wrap="">After some time I give up on and tried to patch szap. Well szap seems to be a wrong version since even used structures in the source code has different names than the ones in the patch file. I got dvb-apps with hg from linuxtv.org.

I'm really down now my hope to get this damn thing running before the first EM match is now not present. Good by HDTV quality games hello PAL...
    </pre>
  </blockquote>
  <pre wrap=""><!---->could you please try whether the simpledvbtune application from 
<a class="moz-txt-link-freetext" href="http://linuxtv.org/pipermail/linux-dvb/2008-April/025535.html">http://linuxtv.org/pipermail/linux-dvb/2008-April/025535.html</a>
works.

---snip---
  </pre>
</blockquote>
I will try that after reinstalling YDL6. Currently I switch between
Fedora9 and YDL6 to see what distribution gives lesser headache.<br>
<blockquote cite="mid:200806070018.16103.dkuhlen@gmx.net" type="cite">
  <pre wrap="">
  </pre>
  <blockquote type="cite">
    <blockquote type="cite">
      <blockquote type="cite">
        <pre wrap="">make[2]: Leaving directory `/usr/src/ps3-linux'
        </pre>
      </blockquote>
    </blockquote>
  </blockquote>
  <pre wrap=""><!---->Are you running this on a PS3? 


 Dominik

  </pre>
</blockquote>
Well yes. *g* My Ps3 is my Multimedia center ^^. Ok its not so Media
center at the moment but it will be...<br>
So all files for me has to be compiled for PPC/PPC64 architecture.<br>
<br>
Ok I can tell that my problem is Distribution <a class="p"
 href="/search?hl=de&amp;sa=X&amp;oi=spell&amp;resnum=0&amp;ct=result&amp;cd=1&amp;q=independent&amp;spell=1">independent</a>.
On Fedora it's a bit harder to get multiproto running (/dev/dvb
appears) but the error with scan and szap is the same ("ioctl
DVBFE_GET_INFO failed: Invalid Argument").<br>
<br>
This time I tried these steps (based on the hints in previous posts)<br>
1. hg clone <a href="http://www.jusst.de/hg/multiproto">http://www.jusst.de/hg/multiproto</a>
<br>
2. cd into multiproto and run "patch -p1 &lt;
patch_add_pctv452e_tt_s2_36x0.diff" (the fixed one from Jens Message at
22:09)
-&gt; no errors<br>
3. run "make" and "make install"
-&gt; well gives compile errors so I followed Faruks instructions<br>
3b) cd to multiproto/linux/drivers/media/video<span
 class="moz-txt-citetags"><br>
 </span>and rename the Makefile to like Makefile_<span
 class="moz-txt-citetags"><br>
</span>after this i won't compile any analog drivers and it will
compile dvb<span class="moz-txt-citetags"><br>
</span>and radio drivers.<br>
3c) 3. run "make clean", "make" and "make install" -&gt;works now<br>
4. hg clone <a href="http://linuxtv.org/hg/dvb-apps">http://linuxtv.org/hg/dvb-apps</a>
<br>
5. cd into dvb-apps and run "patch -p1 &lt; patch_sca_szap.diff"
(attached in the message) -&gt; no errors<br>
 6. copy version.h and frontend.h
-&gt; Well that one was tricky I found out that the place where the
include files are in /usr/include/linux/dvb is that correct. However
after copy them to this location make in the scan and szap directory
works. And make in the dvb-apps now gives an error that Fields are
already defined. Well however thats not in the steps so I do..<br>
7. cd into dvb-apps/util/&lt;scan,szap&gt; and run "make"
-&gt; well that works....to compile<br>
ioctl DVBFE_GET_INFO failed: Invalid Argument...I'm starting to hate
that words...<br>
<br>
What I did not try at the moment:<br>
<pre wrap="">Hmm i really don't know, anyway here is my copy already been patched
and compiled. If the binary scan doesn't work run "make clean" and
then "make"
<a class="moz-txt-link-freetext"
 href="http://www.zshare.net/download/1322006118c9c70a/">http://www.zshare.net/download/1322006118c9c70a/</a>

Faruk
-------------------------------------------
Well and the one I'm not sure about if that is really nesecary when applying the patch from step 5.
</pre>
I'm glad it worked out for you. The dvb-apps scan never worked with<span
 class="moz-txt-citetags"> </span>multiproto <span
 class="moz-txt-citetags"></span>there is another version for
multiproto you can download it from here. <span
 class="moz-txt-citetags"></span><a class="moz-txt-link-freetext"
 href="http://jusst.de/manu/scan.tar.bz2">http://jusst.de/manu/scan.tar.bz2</a><br>
<br>
Michael<br>
</body>
</html>