<br><br><div class="gmail_quote">2008/6/19 Andrew Websdale &lt;<a href="mailto:websdaleandrew@googlemail.com">websdaleandrew@googlemail.com</a>&gt;:<br><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
<br><br><div class="gmail_quote">2008/6/19 Antti Palosaari &lt;<a href="mailto:crope@iki.fi" target="_blank">crope@iki.fi</a>&gt;:<div class="Ih2E3d"><br><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">

<br>Looks like small changes to m9206 driver is needed. MT2060 tuner needs<br>
IF1, i2c-address and output clock bit (0/1 if I remeber correctly..).<br>
Those can be seen from windows sniffs or by guessing / testing. IF1 is<br>
easy to set default one, 1220, wrong IF1 only decreases performance. If<br>
there is eeprom used then value is normally read from there, otherwose<br>
just set default. clock is easy to test. I donĀ“t know how many i2c-address<br>
are supported by chip, but most probably there is not too many. Hopefully<br>
only 4. You can look from specs or from other drivers what i2c-addresses<br>
are used for mt2060. I think it will take 2-10 test to find correct values<br>
by trial and error method.<br>
</blockquote></div></div></blockquote><div><br><br>I&#39;ve tried adding the mt2060 code - it compiles OK &amp; does seem to
be nearly right,the tuner is being recognised, but I think loading the
module causes the I2c bit of the kernel to Oops - would an incorrect
i2c address cause this?<br>
When I get back from work I&#39;ll post my code changes &amp; dmesg output if it helps<br>regards Andrew<br>

&nbsp; <br></div></div><br>