<br><br><div class="gmail_quote">2008/7/2 Antti Palosaari &lt;<a href="mailto:crope@iki.fi">crope@iki.fi</a>&gt;:<br><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
terve Andrew,<br>
Andrew Websdale wrote:<br>
<blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;"><div class="Ih2E3d">
Hi All,<br>
<br>
I&#39;ve been trying to amend the M920x driver to cope with the MT2060 tuner. My dmesg output looks encouraging :<br>
usb 5-1: new high speed USB device using ehci_hcd and address 5<br>
usb 5-1: configuration #1 chosen from 1 choice<br>
Probing for m920x device at interface 0<br>
dvb-usb: found a &#39;Dposh(mt2060 tuner) DVB-T USB2.0&#39; in warm state.<br>
dvb-usb: will pass the complete MPEG2 transport stream to the software demuxer.<br>
DVB: registering new adapter (Dposh(mt2060 tuner) DVB-T USB2.0)<br>
m920x_mt352_frontend_attach<br>
DVB: registering frontend 0 (Zarlink MT352 DVB-T)...<br>
m920x_mt2060_tuner_attach<br>
MT2060: successfully identified (IF1 = 1220)<br>
dvb-usb: Dposh(mt2060 tuner) DVB-T USB2.0 successfully initialized and connected.<br></div>
 &nbsp;but scanning produces no result. I thought it might be the firmware so I used USBSnoop ( ver 2.0 from here &lt;<a href="http://www.pcausa.com/Utilities/UsbSnoop/SniffUSB-x86-2.0.0006.zip" target="_blank">http://www.pcausa.com/Utilities/UsbSnoop/SniffUSB-x86-2.0.0006.zip</a>&gt; &nbsp;, I think its slightly easier to use than the original) and extracted a new firmware file (attached) . The firmware loaded without complaint, but still no scan result. I&#39;m a bit stuck now, anyone got any suggestions as to how I should proceed?<br>

</blockquote>
<br>
I have following list to check:<br>
1) firmware (you tested this one already)<br>
2) demodulator (it is MT352 I think, but configuration / settings could be wrong)<br>
3) wrong endpoint used for mpeg ts<br>
<br>
I can help if you take sniffs with usbsnoop, but hopefully you will find error yourself.<br>
<a href="http://benoit.papillault.free.fr/usbsnoop/" target="_blank">http://benoit.papillault.free.fr/usbsnoop/</a><br>
<br>
regards<br>
Antti<br><font color="#888888">
-- <br>
<a href="http://palosaari.fi/" target="_blank">http://palosaari.fi/</a></font></blockquote><div><br><br><br><br>1)Sorry, forgot to attach firmware I made from usbsnoop(here it is)<br></div></div>2)The front end is MT352 - which configs/settings may need tweaking?<br>
3)Whereabouts is the mpeg ts endpoint defined/set?<br><br>I&#39;ll have another go with usbsnoop later &amp; post the log if I don&#39;t get anywhere<br><br>regards Andrew<br><br><br>