<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
</head>
<body bgcolor="#ffffff" text="#000000">
<br>
Hi everyone,<br>
<br>
I don't know how, I don't know why, but the multiproto drivers are
acting up AGAIN.<br>
<br>
I performed all these steps earlier today on a machine that was running
VDR for months without a problem.<br>
I thought I had purged all of my earlier compiles of multiproto and
mythtv, but somehow it worked on the "dirty" machine and on my new,
completely clean, reinstalled machine it's not working anymore.<br>
<br>
I installed the drivers with these instructions:<br>
<br>
<blockquote>mkdir -p /opt/dvb<br>
cd /opt/dvb<br>
hg clone -r 7218 <a class="moz-txt-link-freetext" href="http://jusst.de/hg/multiproto">http://jusst.de/hg/multiproto</a><br>
cd /opt/dvb/multiproto/v4l<br>
mv compat.h compat.h.untouched<br>
wget <a class="moz-txt-link-freetext" href="http://skerit.kipdola.com/wp-content/uploads/multiproto/compat.h">http://skerit.kipdola.com/wp-content/uploads/multiproto/compat.h</a><br>
cd ..<br>
cd /opt/dvb/multiproto/linux/drivers/media/dvb/frontends<br>
wget
<a class="moz-txt-link-freetext" href="http://skerit.kipdola.com/wp-content/uploads/multiproto/stb6100.c.diff">http://skerit.kipdola.com/wp-content/uploads/multiproto/stb6100.c.diff</a><br>
patch -p0 &lt; stb6100.c.diff<br>
cd /opt/dvb/multiproto/linux/drivers/media/common<br>
wget
<a class="moz-txt-link-freetext" href="http://skerit.kipdola.com/wp-content/uploads/multiproto/TT-3200-remote.patch">http://skerit.kipdola.com/wp-content/uploads/multiproto/TT-3200-remote.patch</a><br>
patch &lt; TT-3200-remote.patch<br>
cd /opt/dvb/multiproto<br>
make<br>
make install<br>
</blockquote>
<br>
And I installed mythtv with these:<br>
<br>
<blockquote>
  <p>cd /opt<br>
svn co <a class="moz-txt-link-freetext" href="http://svn.mythtv.org/svn/branches/release-0-21-fixes/">http://svn.mythtv.org/svn/branches/release-0-21-fixes/</a></p>
  <p>cd /opt/release-0-21-fixes/mythtv/libs/libmythtv<br>
wget
<a class="moz-txt-link-freetext" href="http://svn.mythtv.org/trac/raw-attachment/ticket/5403/mythtv_multiproto.5.patch">http://svn.mythtv.org/trac/raw-attachment/ticket/5403/mythtv_multiproto.5.patch</a><br>
patch &lt; mythtv_multiproto.5.patch<br>
cp /opt/dvb/multiproto/linux/include/linux/dvb/* /usr/include/linux/dvb/<br>
cd /opt/release-0-21-fixes/mythtv<br>
./configure --enable-dvb --dvb-path=/opt/dvb/multiproto/linux/include/<br>
make<br>
make install<br>
cd /opt/release-0-21-fixes/mythtv/database<br>
  <em>mysql</em> <em></em>&lt; <em>mc.sql</em> -p<br>
  </p>
</blockquote>
<p>Now, I'm getting this error message in mythtv:<br>
</p>
<blockquote>2008-07-23 00:05:05.885 DVBSM(0), Error: Can not read DVB
status<br>
&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; eno: Ongeldig argument (22)<br>
2008-07-23 00:05:05.885 DVBSM(0), Warning: Can not measure Signal
Strength<br>
&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; eno: Ongeldig argument (22)<br>
2008-07-23 00:05:05.885 DVBSM(0), Warning: Can not measure S/N<br>
&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; eno: Ongeldig argument (22)<br>
2008-07-23 00:05:05.885 DVBSM(0), Warning: Can not measure Bit Error
Rate<br>
&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; eno: Ongeldig argument (22)<br>
2008-07-23 00:05:05.886 DVBSM(0), Warning: Can not count Uncorrected
Blocks<br>
&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; eno: Bewerking wordt niet ondersteund (95)<br>
mythtv-setup: ../../src/xcb_lock.c:77: _XGetXCBBuffer: Controletest
'((int) ((xcb_req) - (dpy-&gt;request)) &gt;= 0)' faalt.<br>
Afgebroken<br>
</blockquote>
<br>
<div class="moz-signature">-- <br>
<br>
<em>Met vriendelijke groeten,</em>
<br>
<br>
<strong>Jelle De Loecker</strong>
<br>
Kipdola Studios - Tomberg <br>
<br>
</div>
</body>
</html>