<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
  <meta content="text/html;charset=ISO-8859-1" http-equiv="Content-Type">
</head>
<body bgcolor="#ffffff" text="#000000">
Markus Rechberger escreveu:
<blockquote
 cite="mid:d9def9db0808131417t168bc1abvfb3b08101980405d@mail.gmail.com"
 type="cite">
  <pre wrap="">2008/8/13 zePh7r <a class="moz-txt-link-rfc2396E" href="mailto:zeph7r@gmail.com">&lt;zeph7r@gmail.com&gt;</a>:
  </pre>
  <blockquote type="cite">
    <pre wrap="">Albert Comerma escreveu:

Yes, non of the hybrid devices I have worked on have support for analogue,
only dvb. I think the place to look is on video4linux mailing list. If you
want to get support for your card on the kernel (the dvb part) first would
be nice to be sure it works, and then just submit the patch to the linux-dvb
mailing list. I think it should be generated with some options and once it's
generated you should pass the perl script on v4l/scripts/checkpatch.pl to be
sure it follows the programming conventions... Just for curiosity, it worked
just as I send the code or you had to change some things? If you send me
back the files I can generate the patch for you, but again it should be
great to check it really works (you didn't get signal from any spanish
dvb?).

    </pre>
  </blockquote>
  <pre wrap=""><!---->
Hi,

just for your information Empia hybrid devices are fully supported
(FM, analog TV and DVB-T)
mcentral.de has more information about that

Markus
  </pre>
  <blockquote type="cite">
    <pre wrap="">Albert

2008/8/12 zePh7r <a class="moz-txt-link-rfc2396E" href="mailto:zeph7r@gmail.com">&lt;zeph7r@gmail.com&gt;</a>
    </pre>
    <blockquote type="cite">
      <pre wrap="">Albert Comerma escreveu:

I'm happy to hear that. :) it's a shame that you can't try with some dvb
signal, but looks good. I've never used kdetv, so no idea.

Albert

2008/8/12 zePh7r <a class="moz-txt-link-rfc2396E" href="mailto:zeph7r@net.novis.pt">&lt;zeph7r@net.novis.pt&gt;</a>
      </pre>
      <blockquote type="cite">
        <pre wrap="">This is looking good. It seems to load the firmware well. I even ran
kaffeine and it detected my card instantly. However, as there's no dvb-t
service where I live (there's still no dvb-t in Portugal) I can't test it in
full. However I tried to do a channel scan and the signal bar showed high
strength signals multiple times during scan -- which I interpret as a) the
tuner is working, and b) the card is being able to find signal but unable to
decode it since it's not a digital signal. I'm getting this output in dmesg
just for plugging the device into the usb port:

Aug 12 14:29:29 zeph7r-laptop kernel: usb 4-1: new high speed USB device
using ehci_hcd and address 12
Aug 12 14:29:29 zeph7r-laptop kernel: usb 4-1: configuration #1 chosen
from 1 choice
Aug 12 14:29:29 zeph7r-laptop kernel: dvb-usb: found a 'Asus My
Cinema-U3000Hybrid' in cold state, will try to load a firmware
Aug 12 14:29:29 zeph7r-laptop kernel: dvb-usb: downloading firmware from
file 'dvb-usb-dib0700-1.10.fw'
Aug 12 14:29:29 zeph7r-laptop kernel: dib0700: firmware started
successfully.
Aug 12 14:29:30 zeph7r-laptop kernel: dvb-usb: found a 'Asus My
Cinema-U3000Hybrid' in warm state.
Aug 12 14:29:30 zeph7r-laptop kernel: dvb-usb: will pass the complete
MPEG2 transport stream to the software demuxer.
Aug 12 14:29:30 zeph7r-laptop kernel: DVB: registering new adapter (Asus
My Cinema-U3000Hybrid)
Aug 12 14:29:30 zeph7r-laptop kernel: DVB: registering frontend 0 (DiBcom
7000PC)...
Aug 12 14:29:30 zeph7r-laptop kernel: xc2028 2-0061: creating new
instance
Aug 12 14:29:30 zeph7r-laptop kernel: xc2028 2-0061: type set to XCeive
xc2028/xc3028 tuner
Aug 12 14:29:30 zeph7r-laptop kernel: input: IR-receiver inside an USB
DVB receiver as /devices/pci0000:00/0000:00:1d.7/usb4/4-1/input/input13
Aug 12 14:29:30 zeph7r-laptop kernel: dvb-usb: schedule remote query
interval to 150 msecs.
Aug 12 14:29:30 zeph7r-laptop kernel: dvb-usb: Asus My Cinema-U3000Hybrid
successfully initialized and connected.
Aug 12 14:29:30 zeph7r-laptop kernel: usb 4-1: New USB device found,
idVendor=0b05, idProduct=1736
Aug 12 14:29:30 zeph7r-laptop kernel: usb 4-1: New USB device strings:
Mfr=1, Product=2, SerialNumber=3
Aug 12 14:29:30 zeph7r-laptop kernel: usb 4-1: Product: U3000 Hybrid
Aug 12 14:29:30 zeph7r-laptop kernel: usb 4-1: Manufacturer: ASUSTeK
Aug 12 14:29:30 zeph7r-laptop kernel: usb 4-1: SerialNumber: 8110400333
Aug 12 14:29:36 zeph7r-laptop syslog-ng[1724]: STATS: dropped 0


and after starting kaffeine there's still this more:

Aug 12 14:41:31 zeph7r-laptop kernel: xc2028 2-0061: Loading 80 firmware
images from xc3028-v27.fw, type: xc2028 firmware, ver 2.7
Aug 12 14:41:31 zeph7r-laptop kernel: xc2028 2-0061: Loading firmware for
type=BASE F8MHZ (3), id 0000000000000000.
Aug 12 14:41:38 zeph7r-laptop kernel: xc2028 2-0061: Loading firmware for
type=D2620 DTV7 (88), id 0000000000000000.
Aug 12 14:41:38 zeph7r-laptop kernel: xc2028 2-0061: Loading SCODE for
type=DTV8 SCODE HAS_IF_5400 (60000200), id 0000000000000000.
Aug 12 14:42:04 zeph7r-laptop kernel: xc2028 2-0061: Loading firmware for
type=D2620 DTV78 (108), id 0000000000000000.
Aug 12 14:42:04 zeph7r-laptop kernel: xc2028 2-0061: Loading SCODE for
type=DTV8 SCODE HAS_IF_5400 (60000200), id 0000000000000000.


However I also tried kdetv and the card didn't seem to be recognized
here. In the device list there is still only my webcam to choose from. If I
try to run it from a terminal no significant output is shown. How can go
further in testing and getting the analog tv part to work?
        </pre>
      </blockquote>
      <pre wrap="">So, in that case none of the devices you managed to get working so far
(and which seem to be hybrid as well) you didn't get the analog tv part to
work too? It's too bad you can't help me here since for me not having analog
tv (along with the FM tuner) means having a non-functional device.. Anyway,
can you direct me on where to look further in order to pursue the analog
part?
Also, I guess I'd like to contribute back what has been achieved so far
and hope to see native support in kernel in some future release. What can I
do to do that?

Thanks for all the support so far
      </pre>
    </blockquote>
    <pre wrap="">Well I guess not. I'm not living too far from the border but I can't get any
analog spanish tv signal, so I suppose it's normal not to get the dvb too.
But I'm confident it's working. During the scan process signal strength
oscillated often which indicates the tuner is working. The part I'm more
doubtful about is the mpeg decoding which I can't be sure it's working this
way. But in the other hand I'm sure that if I put a note on the wiki
somewhere the next person experimenting with this card will take a look and
report the situation in the mailing lists, don't you agree?
The mailing list to which I primarily wrote (if you remember) was the
video4linux mailing list, as analog support has been always the priority for
me. I noticed you send a message asking for assistance for setting up analog
in the devices you've been dealing with, and just like you i have no idea on
where to start from (I've looked at a topic in wiki called "making your
device being supported" and I came to the wild conclusion that there most
likely is another chipset handling the analog part). But since two is more
that one, perhaps will be able to get somewhere.

Best regards,
--zePh7r


_______________________________________________
linux-dvb mailing list
<a class="moz-txt-link-abbreviated" href="mailto:linux-dvb@linuxtv.org">linux-dvb@linuxtv.org</a>
<a class="moz-txt-link-freetext" href="http://www.linuxtv.org/cgi-bin/mailman/listinfo/linux-dvb">http://www.linuxtv.org/cgi-bin/mailman/listinfo/linux-dvb</a>

    </pre>
  </blockquote>
  <pre wrap=""><!---->
  </pre>
</blockquote>
Thank you so much for the suggestion Markus, I hadn't noticed those
cards were similar to mine yet. I'll be sure to explore that front
during the next days. In your opinion do you think my card shares
similar hardware with those which are already fully supported?<br>
<br>
Best regards,<br>
--zePh7r<br>
</body>
</html>