<div dir="ltr"><meta http-equiv="Content-Type" content="text/html; charset=utf-8"><meta name="ProgId" content="Word.Document"><meta name="Generator" content="Microsoft Word 11"><meta name="Originator" content="Microsoft Word 11"><link rel="File-List" href="file:///D:%5CDOCUME%7E1%5CBhavin%5CLOCALS%7E1%5CTemp%5Cmsohtml1%5C01%5Cclip_filelist.xml"><style>
&lt;!--
 /* Style Definitions */
 p.MsoNormal, li.MsoNormal, div.MsoNormal
        {mso-style-parent:&quot;&quot;;
        margin:0in;
        margin-bottom:.0001pt;
        mso-pagination:widow-orphan;
        font-size:12.0pt;
        font-family:&quot;Times New Roman&quot;;
        mso-fareast-font-family:&quot;Times New Roman&quot;;}
pre
        {margin:0in;
        margin-bottom:.0001pt;
        mso-pagination:widow-orphan;
        font-size:10.0pt;
        font-family:&quot;Courier New&quot;;
        mso-fareast-font-family:&quot;Times New Roman&quot;;}
@page Section1
        {size:8.5in 11.0in;
        margin:1.0in 1.25in 1.0in 1.25in;
        mso-header-margin:.5in;
        mso-footer-margin:.5in;
        mso-paper-source:0;}
div.Section1
        {page:Section1;}
--&gt;
</style><pre>Hi list,
I&#39;ve been struggling hard with getting Twinhan VP 1025 DVB-S PCI card with uBuntu 8.04 - Hardy and latest v4l-dvb source in India. I&#39;m in need of some insight.<span style="">&nbsp; </span><br>
The problem seems to be that the front end is unable to tune to or monitor a signal.<span style="">&nbsp; </span>Here is some background info:<br>
Card:
Twinhan 1025 VisionPlus PCI DVB-S
Kernel/Dist:
2.6.24-19-generic<br>
I just used hg to download the latest v4l-dvb and dvb-apps from Mercurial and everything compiled and installed fine.<span style="">&nbsp; </span>My card is auto detected and loaded by BTTV module. 
<br>
dmesg says:<br>
###############dmesg#####################<br>
Linux video capture interface: v2.00</pre><pre>bttv: driver version 0.9.17 loaded</pre><pre>bttv: using 8 buffers with 2080k (520 pages) each for capture</pre><pre>bttv: Bt8xx card found (0).</pre><pre>ACPI: PCI Interrupt 0000:03:03.0[A] -&gt; GSI 21 (level, low) -&gt; IRQ 21</pre>
<pre>bttv0: Bt878 (rev 17) at 0000:03:03.0, irq: 21, latency: 64, mmio: 0xfafff000</pre><pre>bttv0: detected: Twinhan VisionPlus DVB [card=113], PCI subsystem ID is 1822:0001</pre><pre>bttv0: using: Twinhan DST + clones [card=113,insmod option]</pre>
<pre>bttv0: risc main @ 1eafb000</pre><pre>bttv0: gpio: en=00000000, out=00000000 in=00d500ff [init]</pre><pre>bttv0: tuner type=16</pre><pre>bttv0: add subdevice &quot;dvb0&quot;</pre><pre>bt878: AUDIO driver version 0.0.0 loaded</pre>
<pre>bt878: Bt878 AUDIO function found (0).</pre><pre>ACPI: PCI Interrupt 0000:03:03.1[A] -&gt; GSI 21 (level, low) -&gt; IRQ 21</pre><pre>bt878_probe: card id=[0x11822],[ Twinhan VisionPlus DVB ] has DVB functions.</pre>
<pre>bt878(0): Bt878 (rev 17) at 03:03.1, irq: 21, latency: 64, memory: 0xfaffe000</pre><pre>DVB: registering new adapter (bttv0)</pre><pre>ACPI: PCI Interrupt 0000:00:14.2[A] -&gt; GSI 16 (level, low) -&gt; IRQ 18</pre><pre>
NET: Registered protocol family 10</pre><pre>lo: Disabled Privacy Extensions</pre><pre>hda_codec: Unknown model for ALC883, trying auto-probe from BIOS...</pre><pre>dst(0) dst_get_device_id: Recognise [DST-03T]</pre><pre>
dst(0) dst_get_device_id: Unsupported</pre><pre>dst(0) dst_check_mb86a15: Found a MB86A15 NIM</pre><pre>dst(0) dst_get_device_id: [DST-03T] has a [MB 86A15]</pre><pre>dst(0) dst_get_device_id: [DST-03T] has a [MB 86A15]</pre>
<pre>DST type flags : 0x2 ts204 0x4 symdiv 0x10 firmware version = 2</pre><pre>dst(0) dst_get_mac: MAC Address=[00:08:ca:16:67:00]</pre><pre>DVB: registering frontend 0 (DST DVB-S)...</pre><pre>###########################################<br>

this seems fine to me. Now the problems...<br style="">
</pre><pre>I try to dvbtune to the inset4b, I&#39;m in India but it gives following issues:<br>
# dvbtune -f 10990000 -p V -s 27500 -v 501 -a 601 -m</pre><pre>Using DVB card &quot;DST DVB-S&quot;</pre><pre>tuning DVB-S to L-Band:0, Pol:V Srate=27500000, 22kHz=off</pre><pre>polling....</pre><pre>Getting frontend event</pre>
<pre>FE_STATUS:</pre><pre>polling....</pre><pre>Getting frontend event</pre><pre>FE_STATUS: FE_HAS_SIGNAL FE_HAS_LOCK FE_HAS_CARRIER FE_HAS_VITERBI FE_HAS_SYNC</pre><pre>Event:<span style="">&nbsp; </span>Frequency: 1240000</pre>
<pre><span style="">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; </span>SymbolRate: 27500000</pre><pre><span style="">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; </span>FEC_inner:<span style="">&nbsp; </span>9</pre><pre>Bit error rate: 0</pre><pre>Signal strength: 16384</pre><pre>SNR: 6400</pre><pre>
FE_STATUS: FE_HAS_SIGNAL FE_HAS_LOCK FE_HAS_CARRIER FE_HAS_VITERBI FE_HAS_SYNC</pre><pre>A/V/TT Filters set</pre><pre>FE READ_BER: : Operation not supported</pre><pre>FE READ UNCORRECTED BLOCKS: : Operation not supported</pre>
<pre>Signal=16384, Verror=0, SNR=6400dB, BlockErrors=0, (S|L|C|V|SY|)</pre><pre>FE READ_BER: : Operation not supported</pre><pre>FE READ UNCORRECTED BLOCKS: : Operation not supported</pre><pre>Signal=16640, Verror=0, SNR=6400dB, BlockErrors=0, (S|L|C|V|SY|)</pre>
<pre>FE READ_BER: : Operation not supported……………………..</pre><pre>&nbsp;</pre><pre>&nbsp;</pre><pre>Then I look a dvbsnoop frontend info:
# dvbsnoop -s feinfo<br>
dvbsnoop V1.4.50 -- <a href="http://dvbsnoop.sourceforge.net/">http://dvbsnoop.sourceforge.net/</a> </pre><pre>&nbsp;</pre><pre>---------------------------------------------------------</pre><pre>FrontEnd Info...</pre><pre>---------------------------------------------------------</pre>
<pre>&nbsp;</pre><pre>Device: /dev/dvb/adapter0/frontend0</pre><pre>&nbsp;</pre><pre>Basic capabilities:</pre><pre><span style="">&nbsp;&nbsp;&nbsp; </span>Name: &quot;DST DVB-S&quot;</pre><pre><span style="">&nbsp;&nbsp;&nbsp; </span>Frontend-type:<span style="">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; </span>QPSK (DVB-S)</pre>
<pre><span style="">&nbsp;&nbsp;&nbsp; </span>Frequency (min):<span style="">&nbsp;&nbsp;&nbsp;&nbsp; </span>950.000 MHz</pre><pre><span style="">&nbsp;&nbsp;&nbsp; </span>Frequency (max):<span style="">&nbsp;&nbsp;&nbsp;&nbsp; </span>2150.000 MHz</pre><pre><span style="">&nbsp;&nbsp;&nbsp; </span>Frequency stepsiz:<span style="">&nbsp;&nbsp; </span>1.000 MHz</pre>
<pre><span style="">&nbsp;&nbsp;&nbsp; </span>Frequency tolerance: 29.500 MHz</pre><pre><span style="">&nbsp;&nbsp;&nbsp; </span>Symbol rate (min):<span style="">&nbsp;&nbsp;&nbsp;&nbsp; </span>1.000000 MSym/s</pre><pre><span style="">&nbsp;&nbsp;&nbsp; </span>Symbol rate (max):<span style="">&nbsp;&nbsp;&nbsp;&nbsp; </span>45.000000 MSym/s</pre>
<pre><span style="">&nbsp;&nbsp;&nbsp; </span>Symbol rate tolerance: 0 ppm</pre><pre><span style="">&nbsp;&nbsp;&nbsp; </span>Notifier delay: 0 ms</pre><pre><span style="">&nbsp;&nbsp;&nbsp; </span>Frontend capabilities:</pre><pre><span style="">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; </span>auto inversion</pre>
<pre><span style="">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; </span>FEC AUTO</pre><pre><span style="">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; </span>QPSK</pre><pre>&nbsp;</pre><pre>Current parameters:</pre><pre><span style="">&nbsp;&nbsp;&nbsp; </span>Frequency:<span style="">&nbsp; </span>1240.000 MHz</pre><pre>
<span style="">&nbsp;&nbsp;&nbsp; </span>Inversion:<span style="">&nbsp; </span>OFF</pre><pre><span style="">&nbsp;&nbsp;&nbsp; </span>Symbol rate:<span style="">&nbsp; </span>27.500000 MSym/s</pre><pre><span style="">&nbsp;&nbsp;&nbsp; </span>FEC:<span style="">&nbsp; </span>FEC AUTO</pre>
<pre>&nbsp;</pre><pre>&nbsp;</pre><pre>user@machine:~$ dvbsnoop -s signal</pre><pre>dvbsnoop V1.4.50 -- <a href="http://dvbsnoop.sourceforge.net/">http://dvbsnoop.sourceforge.net/</a> </pre><pre>&nbsp;</pre><pre>---------------------------------------------------------</pre>
<pre>Transponder/Frequency signal strength statistics...</pre><pre>---------------------------------------------------------</pre><pre>Error(95): frontend ioctl: Operation not supported</pre><pre>cycle: 1<span style="">&nbsp; </span>d_time: 0.001 s<span style=""> </span>&nbsp;<br>
</pre><pre>&nbsp;</pre><pre>You can see that the freq is not set.<span style="">&nbsp; </span>An interesting note is that up in the basic capabilities section is lists frequency (max) as 2150.00 MHz.<span style="">&nbsp; </span>Interestingly, when I change my cable to Windows with all the same settings, I am able to tune and lock channels with TwinHan provided SW. <br>
</pre><pre>Am I missing something here? Is the Linux DVB providing support of TwinHan? I would REALLY appreciate any help or insight you might have on this.<span style="">&nbsp; </span>Thanks ton for your consideration.</pre>

<p class="MsoNormal">&nbsp;</p>

</div>