<div dir="ltr">I've just aquired a TerraTec Cinergy 2400i DVB-T PCIe card and am unable to
get it working under Fedora 19 3.11.7-200.fc19.x86_64. I'd very much like
to hear from anyone who is running the card for advice and also some indication whether this is my user error or a driver, distro or software issue.<br>
<br>
The card is reported to work under linux: <<a href="http://linuxtv.org/wiki/index.php/TerraTec_Cinergy_2400i_DVB-T" target="_blank">http://linuxtv.org/wiki/index.php/TerraTec_Cinergy_2400i_DVB-T</a>> and is<br>
detected by lspci.<br>
<br>
$lspci -vvvnn<br>
<br>
02:00.0 Multimedia video controller [0400]: Micronas Semiconductor Holding<br>
AG nGene PCI-Express Multimedia Controller [18c3:0720]<br>
        Subsystem: TERRATEC Electronic GmbH Device [153b:1167]<br>
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-<br>
Stepping- SERR+ FastB2B- DisINTx-<br>
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort-<br>
<TAbort- <MAbort- >SERR- <PERR- INTx-<br>
        Latency: 0, Cache Line Size: 64 bytes<br>
        Interrupt: pin A routed to IRQ 32<br>
        Region 0: Memory at fbbf0000 (32-bit, non-prefetchable) [size=64K]<br>
        Region 1: Memory at fbbe0000 (64-bit, non-prefetchable) [size=64K]<br>
        Capabilities: [40] Power Management version 2<br>
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA<br>
PME(D0-,D1-,D2-,D3hot-,D3cold-<div id=":on">)<br>
                Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-<br>
        Capabilities: [48] MSI: Enable- Count=1/1 Maskable- 64bit+<br>
                Address: 0000000000000000  Data: 0000<br>
        Capabilities: [58] Express (v1) Endpoint, MSI 00<br>
                DevCap: MaxPayload 128 bytes, PhantFunc 0, Latency L0s<br>
<64ns, L1 <1us<br>
                        ExtTag- AttnBtn- AttnInd- PwrInd- RBE- FLReset-<br>
                DevCtl: Report errors: Correctable- Non-Fatal- Fatal-<br>
Unsupported-<br>
                        RlxdOrd- ExtTag- PhantFunc- AuxPwr- NoSnoop+<br>
                        MaxPayload 128 bytes, MaxReadReq 512 bytes<br>
                DevSta: CorrErr- UncorrErr+ FatalErr- UnsuppReq+ AuxPwr-<br>
TransPend-<br>
                LnkCap: Port #0, Speed 2.5GT/s, Width x1, ASPM L0s, Latency<br>
L0 unlimited, L1 unlimited<br>
                        ClockPM- Surprise- LLActRep- BwNot-<br>
                LnkCtl: ASPM Disabled; RCB 64 bytes Disabled- Retrain-<br>
CommClk-<br>
                        ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-<br>
                LnkSta: Speed 2.5GT/s, Width x1, TrErr- Train- SlotClk+<br>
DLActive- BWMgmt- ABWMgmt-<br>
        Capabilities: [100 v1] Device Serial Number 00-00-00-07-20-3c-11-00<br>
        Capabilities: [400 v1] Virtual Channel<br>
                Caps:   LPEVC=0 RefClk=100ns PATEntryBits=1<br>
                Arb:    Fixed- WRR32- WRR64- WRR128-<br>
                Ctrl:   ArbSelect=Fixed<br>
                Status: InProgress-<br>
                VC0:    Caps:   PATOffset=00 MaxTimeSlots=1 RejSnoopTrans-<br>
                        Arb:    Fixed- WRR32- WRR64- WRR128- TWRR128-<br>
WRR256-<br>
                        Ctrl:   Enable+ ID=0 ArbSelect=Fixed TC/VC=ff<br>
                        Status: NegoPending- InProgress-<br>
        Kernel driver in use: ngene<br>
<br>
<br>
$ modinfo ngene<br>
filename:<br>
/lib/modules/3.11.7-200.fc19.x86_64/kernel/drivers/media/pci/ngene/ngene.ko<br>
license:        GPL<br>
author:         Micronas, Ralph Metzler, Manfred Voelkel<br>
description:    nGene<br>
alias:          pci:v000018C3d00000720sv0000153Bsd00001167bc*sc*i*<br>
alias:          pci:v000018C3d00000720sv00001461sd0000062Ebc*sc*i*<br>
alias:          pci:v000018C3d00000720sv000018C3sd0000DD20bc*sc*i*<br>
alias:          pci:v000018C3d00000720sv000018C3sd0000DD10bc*sc*i*<br>
alias:          pci:v000018C3d00000720sv000018C3sd0000DD00bc*sc*i*<br>
alias:          pci:v000018C3d00000720sv000018C3sd0000DB02bc*sc*i*<br>
alias:          pci:v000018C3d00000720sv000018C3sd0000DB01bc*sc*i*<br>
alias:          pci:v000018C3d00000720sv000018C3sd0000ABC4bc*sc*i*<br>
alias:          pci:v000018C3d00000720sv000018C3sd0000ABC3bc*sc*i*<br>
depends:        dvb-core,i2c-core<br>
intree:         Y<br>
vermagic:       3.11.7-200.fc19.x86_64 SMP mod_unload<br>
signer:         Fedora kernel signing key<br>
sig_key:        81:C0:9E:56:78:F2:46:05:66:AF:2E:DE:38:3D:4B:66:D9:CD:13:F7<br>
sig_hashalgo:   sha256<br>
parm:           one_adapter:Use only one adapter. (int)<br>
parm:           shutdown_workaround:Activate workaround for shutdown<br>
problem with some chipsets. (int)<br>
parm:           debug:Print debugging information. (int)<br>
parm:           adapter_nr:DVB adapter numbers (array of short)<br>
<br>
<br>
$ dmesg | grep ngene<br>
[    4.401045] ngene: Found Terratec Integra/Cinergy2400i Dual DVB-T<br>
[    4.401613] ngene: Device version 1<br>
[    4.403282] ngene: Loading firmware file ngene_15.fw.<br>
[    4.473560] ngene 0000:02:00.0: DVB: registering adapter 0 frontend 0<br>
(Micronas DRXD DVB-T)...<br>
[    4.509774] ngene 0000:02:00.0: DVB: registering adapter 1 frontend 0<br>
(Micronas DRXD DVB-T)...<br>
<br>
<br>
<br>
dmesg confirms the driver and firmware are loaded. Channel scanning under 
mythtv, even with an increased signal timeout and tuning timeout, fails to
find any channels - the signal strength sits at 88% throughout and the
Signal / Noise at 12%. Channel scanning under Kaffeine also fails. The card tunes and works fine with the Terratec software under Windows 7.<br>
<br>
<br>
The screen output from mythtv-setup is:<br>
<br>
2014-01-19 19:47:04.652938 I  Current MythTV Schema Version (DBSchemaVer):<br>
1317<br>
2014-01-19 19:47:19.317900 W  DiSEqCDevTree: No device tree for cardid 1<br>
2014-01-19 19:47:19.332598 W  DiSEqCDevTree: No device tree for cardid 5<br>
2014-01-19 19:47:19.336151 W  DiSEqCDevTree: No device tree for cardid 8<br>
2014-01-19 19:47:19.339648 W  DiSEqCDevTree: No device tree for cardid 10<br>
2014-01-19 19:50:17.436930 C  MThread prolog was never run!<br>
2014-01-19 19:50:17.438373 I  ChanImport: No new channels to process<br>
<br>
running Fuser /dev/dvb/adapter0/frontend0 while the scan is running gives
an output of :3760 - so the card is being utilised.<br>
<br>
As the card is the second dual tuner in my myth box, (but occupies devices
/dev/dvb/adapter0  and /dev/dvb/adapter1). I have an already tuned input - on this count the card won't find a a signal
lock if I attach it to working input.<br>
<br>
Any help would be sorely appreciated. Thanks,<br>
<br><div style="text-align:left">
Giles</div></div></div>