[vdr] problem with xine-plugin

Uwe Hanke uhanke at gmx.de
Wed Apr 6 19:41:40 CEST 2005


Hi,

Am Mittwoch, 6. April 2005 18:42 schrieb Borghart:
> hi,
> i want to use vdr on a terratec cinergy t^2.
> therefore i tried to set up a xine plugin for vdr as described here:
> http://www.vdr-wiki.de/wiki/index.php/Xine-plugin
> compilation went without any problems so far, but stuff isn't working
> anyhow:
> when i start vdr /var/log/messages says:
>
> Apr  6 18:31:23 fozzy vdr[4319]: VDR version 1.2.6 started
> Apr  6 18:31:23 fozzy vdr[4319]: loading /video/setup.conf
> Apr  6 18:31:23 fozzy vdr[4319]: loading /video/sources.conf
> Apr  6 18:31:23 fozzy vdr[4319]: loading /video/channels.conf
> Apr  6 18:31:23 fozzy vdr[4319]: loading /video/remote.conf
> Apr  6 18:31:23 fozzy vdr[4319]: found 1 video device
> Apr  6 18:31:23 fozzy vdr[4319]: setting primary device to 1
> Apr  6 18:31:23 fozzy vdr[4319]: device 1 has no MPEG decoder
> Apr  6 18:31:23 fozzy vdr[4319]: SVDRP listening on port 2001
> Apr  6 18:31:23 fozzy vdr[4319]: switching to channel 1
>
> which looks o.k. to me + no errors/warnings in /var/log/syslog.
> ...
no errors but xine-plugin is missing, start vdr with -P xine or -P 'xine -r', 
then log looks like this:

Mar 25 15:06:25 uha-asus vdr[3391]: VDR version 1.3.22 started
Mar 25 15:06:25 uha-asus vdr[3391]: loading 
plugin: ./PLUGINS/lib/libvdr-xine.so.1.3.22
Mar 25 15:06:26 uha-asus vdr[3391]: loading /video/setup.conf
Mar 25 15:06:26 uha-asus vdr[3391]: loading /video/sources.conf
Mar 25 15:06:26 uha-asus vdr[3391]: loading /video/diseqc.conf
Mar 25 15:06:26 uha-asus vdr[3391]: loading /video/channels.conf
Mar 25 15:06:26 uha-asus vdr[3391]: loading /video/timers.conf
Mar 25 15:06:26 uha-asus vdr[3391]: loading /video/svdrphosts.conf
Mar 25 15:06:26 uha-asus vdr[3391]: loading /video/ca.conf
Mar 25 15:06:26 uha-asus vdr[3391]: loading /video/remote.conf
Mar 25 15:06:26 uha-asus vdr[3391]: loading /video/keymacros.conf
Mar 25 15:06:26 uha-asus vdr[3391]: reading EPG data from /video/epg.data
Mar 25 15:06:26 uha-asus vdr[3391]: probing /dev/dvb/adapter0/frontend0
Mar 25 15:06:26 uha-asus vdr[3391]: probing /dev/dvb/adapter1/frontend0
Mar 25 15:06:26 uha-asus vdr[3391]: found 1 video device
Mar 25 15:06:26 uha-asus vdr[3391]: initializing plugin: xine (0.7.2): 
Software based playback using xine
Mar 25 15:06:26 uha-asus vdr[3407]: tuner on device 1 thread started 
(pid=3407, tid=16386)
Mar 25 15:06:26 uha-asus vdr[3408]: Section handler thread started (pid=3408, 
tid=32771)
Mar 25 15:06:26 uha-asus vdr[3409]: XineRemote control thread started 
(pid=3409, tid=49156)
Mar 25 15:06:26 uha-asus vdr[3409]: Entering cXineRemote thread 
Mar 25 15:06:26 uha-asus vdr[3391]: setting primary device to 1
Mar 25 15:06:26 uha-asus vdr[3391]: device 1 has no MPEG decoder
Mar 25 15:06:26 uha-asus vdr[3391]: trying device number 2 instead
Mar 25 15:06:26 uha-asus vdr[3391]: setting primary device to 2
...

Cheers, Uwe



More information about the vdr mailing list