[vdr] problem vdr-xine-0.7.3 plugin

Jouni Karvo jouni.karvo at tkk.fi
Thu Apr 14 21:38:55 CEST 2005


hi,

After updating to this version (0.7.3) there are some changes:

(I have also the combined ttxtsubs and subtitles patch from
  http://users.tkk.fi/~rahrenbe/vdr/)

- remote control is much more responsive and does not queue requests
  any more 
- after some 15-20 secs of live TV (with budget) the sound (and
  sometimes also images) start to have problems.  The VDR output says

AFD present: 8
AFD present: 8
bad_frame
bad_frame
bad_frame
bad_frame
bad_frame
bad_frame
bad_frame
bad_frame
bad_frame
bad_frame
bad_frame
AFD present: 8

- when viewing recordings, vdr-xine recovers from this in a second or
  two and continues then some time without problems, then stutters
  again

This is a more detailed log from a live viewing:

AFD present: 8
bad_frame
bad_frame
bad_frame
6
set_speed 176682
set_speed 238422
set_speed 331537
set_speed 448159
set_speed 534008
set_speed 664190
set_speed 886085
set_speed 960757
set_speed 1000000
200 frames delivered, 3 frames skipped, 7 frames discarded
audio discontinuity #10, type is 2, disc_off 7484075394
waiting for in_discontinuity update #10
video discontinuity #10, type is 2, disc_off 7484075394
audio vpts adjusted to audio vpts
audio jump, diff=100859
audio discontinuity #11, type is 2, disc_off 7484118594
waiting for in_discontinuity update #11
video discontinuity #11, type is 2, disc_off 7484118594
audio vpts adjusted to audio vpts
audio jump, diff=105179
fixing sound card drift by 3514 pts
fixing sound card drift by 2632 pts
fixing sound card drift by 1971 pts
fixing sound card drift by 1475 pts
audio discontinuity #12, type is 2, disc_off 7494659394
waiting for in_discontinuity update #12
video discontinuity #12, type is 2, disc_off 7494659394
audio vpts adjusted to audio vpts
audio jump, diff=115979
audio discontinuity #13, type is 2, disc_off 7494702594
waiting for in_discontinuity update #13
video discontinuity #13, type is 2, disc_off 7494702594
audio vpts adjusted to audio vpts
audio jump, diff=113819

Earlier, there were some occasional "chirp" sounds, but then the audio
and video continued without any more pausing and got over the error.
For some reason now it seems to not be able to recover from these
errors. 

Any ideas on what to try - should I add some additional logging
commands? 

yours,
		Jouni




More information about the vdr mailing list