[vdr] Centralized 'thread active' handling

Luca Olivetti luca at ventoso.org
Sat Aug 13 16:30:35 CEST 2005


Stefan Huelswitt wrote:
> Wouldn't it be better to leave Active() untouched (instead of
> renaming to Running()) and create a new (differently named)
> function for the active var replacement? (e.g. Continue(), which
> would give good readability with while(Continue()))

In that case I'd suggest Terminated()

    while(!Terminated())

it would somewhat reduce my confusion when switching from the elegance 
of delphi/lazarus to the awkwardness of C++ ;-)

Bye

-- 
- Yo también quiero una Europa libre de Patentes de Software  -
- I want a Software Patents Free Europe too! And you?         -
---------------------------------------------------------------
   EuropeSwPatentFree - http://EuropeSwPatentFree.hispalinux.es
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 256 bytes
Desc: OpenPGP digital signature
Url : http://www.linuxtv.org/pipermail/vdr/attachments/20050813/92fea0e8/signature.pgp


More information about the vdr mailing list