[vdr] Centralized 'thread active' handling

Stefan Huelswitt s.huelswitt at gmx.de
Sat Aug 13 16:57:39 CEST 2005


On 13 Aug 2005 Klaus Schmidinger <Klaus.Schmidinger at cadsoft.de> wrote:
> Stefan Huelswitt wrote:
>> 
>> Wouldn't it be better to leave Active() untouched (instead of
>> renaming to Running()) and create a new (differently named)
>> function for the active var replacement? (e.g. Continue(), which
>> would give good readability with while(Continue()))
> 
> Well, Active() reflects the internal 'active' variable, so
> Continue() would have to correspond to 'continue', which is
> a reserved keyword...

This is after your change, but before Active() didn't reflected
any internal variable. I don't know if one must build such a
strict rule ...

Just my two cents.

Regards.

-- 
Stefan Huelswitt
s.huelswitt at gmx.de  | http://www.muempf.de/



More information about the vdr mailing list