[vdr] streamdev-client and softdevice

Henrik Niehaus henrik.niehaus at gmx.de
Fri Aug 19 13:04:34 CEST 2005


Stefan Lucke schrieb:

>On Donnerstag, 18. August 2005 16:29, Henrik Niehaus wrote:
>  
>
>>Henrik Niehaus schrieb:
>>    
>>
>
>  
>
>>>ok, the vdr has a full featured and a budget tuner.
>>>the client log:
>>>[softdevice] processing args
>>>[softdevice]   argv [0] = softdevice
>>>[softdevice]   argv [3] = -L
>>>[setup-softdevice] alsa ac3Mode set to: 0
>>>[setup-softdevice] alsa device set to: default
>>>[setup-softdevice] A/V Offset set to (0)
>>>[setup-softdevice] cropping mode set to 0 (none)
>>>[setup-softdevice] cropping mode toggle key set to 0 (none)
>>>[setup-softdevice] deinterlace method set to 0 none
>>>[softdevice] picture mirroring set to 0 (off)
>>>[setup-softdevice] pixel format set to (I420)
>>>[setup-softdevice] shouldSuspend to: 0
>>>[setup-softdevice] startup aspect set to (4:3 normal)
>>>[softdevice] initializing Plugin
>>>[softdevice] Initializing Video Out
>>>[softdevice] ffmpeg version(0.4.9-pre1) build(4718)
>>>[XvVideoOut]: max area size 2046 x 2046
>>>[XvVideoOut]: using area size 736 x 576
>>>Subplugin successfully opend
>>>[softdevice] Video Out seems to be OK
>>>[softdevice] Initializing Audio Out
>>>[softdevice] Audio out seems to be OK
>>>[softdevice] A/V devices initialized, now initializing MPEG2 Decoder
>>>cSoftDevice::MakePrimaryDevice
>>>
>>>and the server log:
>>>Aug 14 00:10:16 htpc user.info vdr[1136]: Streamdev: Accepted new client
>>>(VTP) 192.168.0.1:32786
>>>Aug 14 00:10:36 htpc user.debug vdr[1282]: receiver on device 2 thread
>>>started (pid=1282, tid=31755)
>>>Aug 14 00:10:36 htpc user.debug vdr[1275]: TS buffer on device 2 thread
>>>ended (pid=1275, tid=30732)
>>>Aug 14 00:10:36 htpc user.debug vdr[1282]: buffer stats: 0 (0%) used
>>>Aug 14 00:10:36 htpc user.debug vdr[1283]: TS buffer on device 2 thread
>>>started (pid=1283, tid=32780)
>>>Aug 14 00:10:39 htpc user.err vdr[1136]: ERROR: thread 31755 won't end
>>>(waited 3 seconds) - cancelling it...
>>>Aug 14 00:10:39 htpc user.info vdr[1136]: Streamdev: Accepted new client
>>>(VTP) 192.168.0.1:32787
>>>Aug 14 00:10:39 htpc user.info vdr[1136]: Streamdev: Client (VTP)
>>>192.168.0.1:32786 closed connection
>>>Aug 14 00:10:39 htpc user.info vdr[1136]: Streamdev: Closing connection
>>>to 192.168.0.1:32786
>>>Aug 14 00:10:39 htpc user.debug vdr[1284]: receiver on device 2 thread
>>>started (pid=1284, tid=33803)
>>>Aug 14 00:10:39 htpc user.debug vdr[1283]: TS buffer on device 2 thread
>>>ended (pid=1283, tid=32780)
>>>Aug 14 00:10:39 htpc user.debug vdr[1284]: buffer stats: 0 (0%) used
>>>Aug 14 00:10:39 htpc user.debug vdr[1285]: TS buffer on device 2 thread
>>>started (pid=1285, tid=34828)
>>>Aug 14 00:10:42 htpc user.err vdr[1136]: ERROR: thread 33803 won't end
>>>(waited 3 seconds) - cancelling it...
>>>Aug 14 00:10:42 htpc user.debug vdr[1136]: buffer stats: 0 (0%) used
>>>Aug 14 00:10:42 htpc user.info vdr[1136]: Streamdev: Accepted new client
>>>(VTP) 192.168.0.1:32788
>>>Aug 14 00:10:42 htpc user.info vdr[1136]: Streamdev: Client (VTP)
>>>192.168.0.1:32787 closed connection
>>>Aug 14 00:10:42 htpc user.info vdr[1136]: Streamdev: Closing connection
>>>to 192.168.0.1:32787
>>>Aug 14 00:10:42 htpc user.info vdr[1136]: Streamdev: Client (VTP)
>>>192.168.0.1:32788 closed connection
>>>Aug 14 00:10:42 htpc user.info vdr[1136]: Streamdev: Closing connection
>>>to 192.168.0.1:32788
>>>Aug 14 00:10:58 htpc user.info vdr[1136]: Streamdev: Accepted new client
>>>(VTP) 192.168.0.1:32789
>>>Aug 14 00:11:00 htpc user.info vdr[1136]: Streamdev: Closing connection
>>>to 192.168.0.1:32789
>>>
>>>the osd appears, but no video and no audio.
>>>      
>>>
>
>  
>
>>no ideas for this problem?
>>    
>>
>
>Yes, no concrete ideas. Did you check the streamdev-server parameters,
>$CONFIG_DIR/plugins/streamdevhosts.conf - who is allowed to connect
>and in $CONFIG_DIR/setup.conf (streamdev settings of the server
>max clients, port, stream type). 
>  
>
the setup should be ok, since i had one successful streamsession...

>But as server is accepting the client connecting and starts a receiver
>on your 2nd card . . . . I wonder why the buffer of that attached
>receiver is not filled. Dish cable connected ?
>
>  
>
the setup of vdr should be ok, too. simple streaming with xine works great.



More information about the vdr mailing list