[vdr] rcu and vdr 1.3

Eric Laly elaly at free.fr
Tue Aug 23 00:57:22 CEST 2005


Hello all,

I ave a fully fonctionnal vdr-1.2.6 with dvb-kernel for kernel-2.4 and a
RCU unit.

I've some spare time, so I've decided to give vdr-1.3 a try.

First, I'm installing kernel 2.6.12.5 instaed of 2.4.27: vdr-1.2.6 is
always functionnal with 2.6.

Second I'm installing a vanilla vdr-1.3.30 with an other /video (only
the .conf of VDR into and the remote.conf of vdr-1.2.6) , and this is
the problem with RCU: no "HELO" and no remote.
the log:
Aug 23 00:20:59 vdr vdr[13069]: VDR version 1.3.30 started
Aug 23 00:20:59 vdr vdr[13069]: loading /video/sources.conf
Aug 23 00:20:59 vdr vdr[13069]: loading /video/diseqc.conf
Aug 23 00:20:59 vdr vdr[13069]: loading /video/channels.conf
Aug 23 00:20:59 vdr vdr[13069]: loading /video/svdrphosts.conf
Aug 23 00:20:59 vdr vdr[13069]: loading /video/ca.conf
Aug 23 00:20:59 vdr vdr[13069]: loading /video/remote.conf
Aug 23 00:20:59 vdr vdr[13069]: loading /video/keymacros.conf
Aug 23 00:21:01 vdr vdr[13069]: found 2 video devices
Aug 23 00:21:01 vdr vdr[13069]: setting primary device to 1
Aug 23 00:21:01 vdr vdr[13069]: SVDRP listening on port 2001
Aug 23 00:21:01 vdr vdr[13069]: loading /video/themes/sttng-default.theme
Aug 23 00:21:01 vdr vdr[13069]: loading /video/themes/sttng-default.theme
Aug 23 00:21:01 vdr vdr[13069]: connecting to RCU remote control using
code C
Aug 23 00:21:01 vdr vdr[13069]: switching to channel 1


If I stop vdr-1.3.30 and I start vdr-1.2.6 (with its /video): all is
working. (and if I make a 'cat /dev/ttyS1', I can see the code from the
remote when I'm pressing a key) so the problem is not from the RCU, the
COM port or the driver of the port com.

With vdr-1.3.30, if I suppress the remote.conf to make a new remote
learning, there is no 'COdE' on the four digits display and the RCU
doesn't recognize the remote (I've made the test with vdr-1.2.6 and this
is working).
the log:
Aug 23 00:08:15 vdr vdr[11084]: VDR version 1.3.30 started
Aug 23 00:08:15 vdr vdr[11084]: loading /video/sources.conf
Aug 23 00:08:15 vdr vdr[11084]: loading /video/diseqc.conf
Aug 23 00:08:15 vdr vdr[11084]: loading /video/channels.conf
Aug 23 00:08:15 vdr vdr[11084]: loading /video/svdrphosts.conf
Aug 23 00:08:15 vdr vdr[11084]: loading /video/ca.conf
Aug 23 00:08:15 vdr vdr[11084]: loading /video/keymacros.conf
Aug 23 00:08:17 vdr vdr[11084]: found 2 video devices
Aug 23 00:08:17 vdr vdr[11084]: setting primary device to 1
Aug 23 00:08:17 vdr vdr[11084]: SVDRP listening on port 2001
Aug 23 00:08:17 vdr vdr[11084]: loading /video/themes/sttng-default.theme
Aug 23 00:08:17 vdr vdr[11084]: loading /video/themes/sttng-default.theme
Aug 23 00:08:17 vdr vdr[11084]: trying codes for RCU remote control...

My config:
Debian stable/testing
gcc-3.3.5
kernel 2.6.12.5


If someone can help...

Thank in advance.

Eric.



More information about the vdr mailing list