[vdr] RE: ERROR: can't set filter (pid=110, tid=02, mask=FF): Device or resource busy

Martin Dauskardt md001 at gmx.de
Fri Aug 26 22:59:13 CEST 2005


>
> Have you tested all versions between 1.3.24 and 1.3.30?
> It would help if we knew which version change exactly causes this.
>
> Oh, and please try without any patches or plugins (as far as possible).

o.k., I will make some tests with 1.3.29 and earlier

I just made a short test with vdr 1.3.30, to confirm the problem: yes, again
it took only a few minutes to freeze.
This time I had started the EPG scan manually befor. With other vdr
versions, I usually get a black picture at this moment, but it is possible
to switch back to the channel. With vdr 1.3.30, the picture freezes in a
funny way: The frozen picture contains of two halfs with the same content.
Sorry, I can`t describe it better in english.
(Das Bild besteht aus zwei Halften, von denen beide den gleichen Bildinhalt
haben)

I pressed "2" and the ZDF picture appears back. After about a minute, the
picture freezes and the log shows the "can`t set filter"-error. It seems
that the problem only appears during an EPG scan.

Then I set "EPG scan timeout" to 0 ,and now there are no freezes!

It seems that the other problem I posted (live picture freezes when
recording starts) does not appear als long as there is no EPG scan running.

My machine has a Fuji DVB-C with CI-modul (but no alphacrypt inside) and a
Lorenzen DVB-T card. I use the old DVB HEAD driver for 2.4






More information about the vdr mailing list