[vdr] two card system is not working

I.Seeberg iseeberg at gmx.de
Wed Aug 31 09:17:44 CEST 2005


Hello,
a few days ago I posted already but since then I worked some things out.
So I'd like to start a new thread.

I upgraded my vdr system with another Skystar 2 (Rev. 2.3) DVB-S card.
Using the kernel drivers from kernel 2.6.12.5 with upgraded
DVB-patch.2.6.12 from Linuxtv.org (to match last recent dvb-kernel version).

VDR is not working as expected. Without recordings everything is fine.
But if a recording (due to a timer event or manual) starts vdr gets very
slow and the recording isn't starting.
Well, it starts and in the same second it stopps, and that happends
continuously every 6 seconds.
I would expect VDR to get me an error. Instead the SkyStar driver
(b2c2-flexcop-pci) is flooding my dmesg log with "i2c: master xfer
failed" messages.

Without loading the skystar card driver and using the single DVB setup
everything works just fine again because the full featured Nexus 2.1
(primary) works well.

Output of 'cat /proc/interrupts' is:

 10:          0          XT-PIC  Technisat/B2C2 FlexCop II/IIb/III
Digital TV PCI Driver
 11:      31472          XT-PIC  saa7146 (0), eth0

And 2 devices were found by vdr.
There are no counted interrups on irq 10 for the SkyStar2 it seems that
the card / interrupt is sleeping since start of the vdr program (and I
know about the "Einschlafproblem" but this occurs not just by starting
the vdr or driver, right?).

Using the command
    ./szap -n 002 -a 1 -f 0
leads like starting a recording on the device into floading the dmesg logs.
szap output:
    reading channels from file '/root/.szap/channels.conf'
    zapping to 2 'Das Erste;ARD':
    sat 0, frequency = 11837 MHz H, symbolrate 27500000, vpid = 0x0065,
apid = 0x0066
    using '/dev/dvb/adapter1/frontend0' and '/dev/dvb/adapter1/demux0'
    status 01 | signal 0000 | snr 9b85 | ber 00000000 | unc 00000000 |
    status 01 | signal 0000 | snr b097 | ber 00000000 | unc 00000000 |
    status 01 | signal 0000 | snr cfdf | ber 00000000 | unc 00000000 |
    status 01 | signal 0000 | snr c829 | ber 00000000 | unc 00000000 |
    (...)

Instead using the ff device:
    zapping to 2 'Das Erste;ARD':
    sat 0, frequency = 11837 MHz H, symbolrate 27500000, vpid = 0x0065,
apid = 0x0066
    using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
    status 01 | signal 8ea8 | snr 9840 | ber 0000ff0a | unc 00000000 |
    status 1f | signal ad1e | snr ce49 | ber 00003300 | unc 00000000 |
FE_HAS_LOCK
    status 1f | signal ac85 | snr ce10 | ber 00000000 | unc 00000000 |
FE_HAS_LOCK

If there's somebody having an idea it would be welcome because I'm
running low on ideas what to do next.

Who else uses the SkyStar 2 Rev 2.3 and has no problems?
Might be, that it's an overheating problem - but my pc case is open and
there's a fan just in front of the pci cards.


Greetings,
Ingo


VDR Logs:




More information about the vdr mailing list