[vdr] vdr 1.2.6 and 1.3.17

Simon Baxter linuxtv at nzbaxters.com
Sat Feb 19 16:18:18 CET 2005


This is the first time I'v tried to get VDR working.  Have a budget card (with no decoder) so had to extend xine with the vdr plugins.  This seems to be working.  when I run "xine --verbose=2" I can see the vdr drivers being loaded.  Next step get VDR working

I've followed all the xine plugin directions and got as far as ./runvdr "'-Pxine -r'" in the INSTALL


[root at nzbaxters VDR]# ./runvdr "'-Pxine -r'"
/bin/sh: line 0: cd: /usr/src/linux-2.6.9-rc4: No such file or directory
head: cannot open `/fifty/data/Packages/video/DVB/driver/DVB/include/linux/dvb/version.h' for reading: No such file or directory
/bin/sh: line 0: cd: /usr/src/linux-2.6.9-rc4: No such file or directory
Makefile:113: /fifty/data/Packages/video/DVB/driver/Rules.make: No such file or directory
make: *** No rule to make target `/fifty/data/Packages/video/DVB/driver/Rules.make'.  Stop.
[root at nzbaxters VDR]#


I'm not sure why it's trying to call linux-2.6.9-rc4 but suspect I needed to get a new VDR source and start again.  Since first playing with all this I have moved from FC2 to FC3 and changed kernels several times, until getting the DVB card working properly (as tested with xine natively and mplayer, tzap, scan, etc etc).



In looking for a new vdr source, saw the vdr-1.3.17-0.16.rpm was available, so rpm -Uvh'd it.  I now have 1.2.6 complied and available in one directory, and 1.3.17 rpm'd and installed in /usr/bin

When I try running the same commands:
[root at nzbaxters bin]# pwd
/usr/bin
[root at nzbaxters bin]# ./runvdr "'-Pxine -r'"
./runvdr: line 32: cd: ../DVB/driver: No such file or directory
make: *** No rule to make target `insmod'.  Stop.
bash: ./vdr: No such file or directory
Sat Feb 19 15:13:28 GMT 2005
restarting VDR
./vdr: No such file or directory
./runvdr: line 42: cd: ../DVB/driver: No such file or directory
make: *** No rule to make target `rmmod'.  Stop.
make: *** No rule to make target `insmod'.  Stop.
Sat Feb 19 15:13:38 GMT 2005
bash: ./vdr: No such file or directory
Sat Feb 19 15:13:38 GMT 2005
restarting VDR
./vdr: No such file or directory

[root at nzbaxters bin]# vdr
vdr: warning: NPTL is active - there may be problems
vdr: please turn off UTF-8 before starting VDR
[root at nzbaxters bin]#


Any suggestions?  Should I get a recent 1.3.x VDR source and patch in the xine plugin?  Can I get the 1.3.17 working 'out of the box' ?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.linuxtv.org/pipermail/vdr/attachments/20050219/10b05eeb/attachment.html


More information about the vdr mailing list