[vdr] can't get xine plugin to work

Simon Baxter linuxtv at nzbaxters.com
Sun Feb 20 21:20:24 CET 2005


I've installed the vdr-xine plugin "2005-02-13: Version 0.7.1"

When xine starts I can see some vdr references :
xine --verbose=2
load_plugins: plugin /usr/local/lib/xine/plugins/1.0.0/post/xineplug_post_vdr.so found
load_plugins: plugin /usr/local/lib/xine/plugins/1.0.0/xineplug_inp_vdr.so found


but when vdr starts, there's an error.  I start xine in one window
then
./vdr -w 60 -Pxine

and /var/log/messages looks like :
Feb 20 20:06:54 nzbaxters vdr[6491]: VDR version 1.2.6 started
Feb 20 20:06:54 nzbaxters vdr[6491]: loading plugin: ./PLUGINS/lib/libvdr-xine.s
o.1.2.6
Feb 20 20:06:54 nzbaxters vdr[6491]: loading /fifty/video/sources.conf
Feb 20 20:06:54 nzbaxters vdr[6491]: loading /fifty/video/channels.conf
Feb 20 20:06:54 nzbaxters vdr[6491]: found 1 video device
Feb 20 20:06:54 nzbaxters vdr[6491]: initializing plugin: xine (0.7.1): Software based playback using xine
Feb 20 20:06:54 nzbaxters vdr[6491]: setting primary device to 1
Feb 20 20:06:54 nzbaxters vdr[6491]: device 1 has no MPEG decoder
Feb 20 20:06:54 nzbaxters vdr[6491]: trying device number 2 instead
Feb 20 20:06:54 nzbaxters vdr[6491]: setting primary device to 2
Feb 20 20:06:54 nzbaxters vdr[6491]: SVDRP listening on port 2001
Feb 20 20:06:54 nzbaxters vdr[6491]: starting plugin: xine
Feb 20 20:06:54 nzbaxters vdr[6491]: ERROR: remote control XineRemote not ready!

then I have to CTRL-c the ./vdr app. 


Also, even though the xine patches were applied to the xine-ui, I don't see the vdr keys on the xine app.  Should I?



if I start vdr without the plugin, it does :
Feb 20 20:17:48 nzbaxters vdr[6583]: VDR version 1.2.6 started
Feb 20 20:17:48 nzbaxters vdr[6583]: loading /fifty/video/sources.conf
Feb 20 20:17:48 nzbaxters vdr[6583]: loading /fifty/video/channels.conf
Feb 20 20:17:48 nzbaxters vdr[6583]: found 1 video device
Feb 20 20:17:48 nzbaxters vdr[6583]: setting primary device to 1
Feb 20 20:17:48 nzbaxters vdr[6583]: device 1 has no MPEG decoder
Feb 20 20:17:48 nzbaxters vdr[6583]: SVDRP listening on port 2001


??
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.linuxtv.org/pipermail/vdr/attachments/20050220/45f377af/attachment.htm


More information about the vdr mailing list