[vdr] Hauppauge LIRC remote, FC3, buttons

Darren Salt linux at youmustbejoking.demon.co.uk
Fri Feb 25 19:22:26 CET 2005


I demand that Simon Baxter may or may not have written...

> From: "Darren Salt" <linux at youmustbejoking.demon.co.uk>
>> The -kernel patch is applicable to 2.6.x kernel source and the LinuxTV DVB
>> driver tarballs (1.1.0, 1.1.1 and possibly some older versions); the
>> -linuxtv patch is for DVB CVS (and *should* still be applicable; I've not
>> checked recently). For the record, these are based on the IR keymap
>> interface in the av7110 code.

> Please excuse my ignorance, but do I need to patch and compile both the
> kernel and the DVB-CVS?

No. Only whichever you intend to use.

> Or should I use the -kernel patch for if I'm doing DVB in the kernel tree
> and -linuxtv if I'm doing DVB outside the kernel tree?

For the kernel DVB drivers, that's correct. (I'm using that patch with
2.6.10 and previously with 2.6.8.1.)

For drivers sourced from the LinuxTV site, it depends on the age of the
drivers. The -kernel driver wasn't applicable without rejects to driver
source from CVS when I last checked, which is why there are two versions of
the patch; if the -linuxtv patch isn't cleanly applicable any more, then feel
free to post a fixed-up patch :-)

As usual with this kind of thing, testing whether the patch is applicable by
using patch's --dry-run option is recommended.

-- 
| Darren Salt | nr. Ashington, | d youmustbejoking,demon,co,uk
| Debian,     | Northumberland | s zap,tartarus,org
| RISC OS     | Toon Army      | @
|   Retrocomputing: a PC card in a Risc PC

Congratulations! You are the 16,777,216th user to login to our system.



More information about the vdr mailing list