[vdr] VDR cannot tune

Matthias Fechner idefix at fechner.net
Sat Jul 16 10:32:28 CEST 2005


Hi,

i changed some days ago to kernel 2.6.13-rc1 with cvs-head driver and
the newest firmware.
Now i switched on my tv and the screen was black.
If i try to change the channel, i only see a black screen (menu is
working fine and i can replay recordings).

If i look in the logfile i found:
--- cut ---
Jul 16 10:16:20 [vdr] buffer stats: 0 (0%) used
Jul 16 10:16:20 [vdr] receiver on device 1 thread started (pid=4202, tid=10600456)
Jul 16 10:16:20 [vdr] TS buffer on device 1 thread started (pid=4203, tid=10616841)
Jul 16 10:16:20 [vdr] Text2Skin: channelInfo display update thread started (pid=4204, tid=10633226)
Jul 16 10:16:25 [vdr] Text2Skin: channelInfo display update thread ended (pid=4204, tid=10633226)
Jul 16 10:16:34 [vdr] Text2Skin: channelInfo display update thread started (pid=4262, tid=10649610)
Jul 16 10:16:34 [vdr] Text2Skin: channelInfo display update thread ended (pid=4262, tid=10649610)
Jul 16 10:16:42 [vdr] Text2Skin: menu display update thread started (pid=4282, tid=10665994)
Jul 16 10:16:42 [vdr] max. latency time 15 seconds
Jul 16 10:16:42 [vdr] Text2Skin: menu display update thread ended (pid=4282, tid=10665994)
Jul 16 10:16:43 [vdr] ERROR: can't set filter (pid=18, tid=4E, mask=FE): Operation not permitted
Jul 16 10:16:43 [vdr] ERROR: can't set filter (pid=18, tid=50, mask=F0): Operation not permitted
Jul 16 10:16:43 [vdr] ERROR: can't set filter (pid=18, tid=60, mask=F0): Operation not permitted
Jul 16 10:16:43 [vdr] ERROR: can't set filter (pid=20, tid=70, mask=FF): Operation not permitted
Jul 16 10:16:43 [vdr] ERROR: can't set filter (pid=0, tid=00, mask=FF): Operation not permitted
Jul 16 10:16:43 [vdr] ERROR: can't set filter (pid=17, tid=42, mask=FF): Operation not permitted
Jul 16 10:16:43 [vdr] ERROR: can't set filter (pid=16, tid=40, mask=FF): Operation not permitted
Jul 16 10:17:14 [vdr] Text2Skin: menu display update thread started (pid=4447, tid=10682378)
Jul 16 10:17:16 [vdr] Text2Skin: menu display update thread ended (pid=4447, tid=10682378)
Jul 16 10:17:17 [vdr] switching to channel 9
Jul 16 10:17:17 [vdr] TS buffer on device 1 thread ended (pid=4203, tid=10616841)
Jul 16 10:17:17 [vdr] buffer stats: 0 (0%) used 
Jul 16 10:17:17 [vdr] receiver on device 1 thread ended (pid=4202, tid=10600456)
Jul 16 10:17:17 [vdr] buffer stats: 0 (0%) used
Jul 16 10:17:17 [vdr] creating directory /vtx/S19.2E-133-33-898
Jul 16 10:17:22 [vdr] ERROR: device 1 has no lock, can't attach receiver!
Jul 16 10:17:22 [vdr] Text2Skin: channelInfo display update thread started (pid=4472, tid=10698759)
Jul 16 10:17:27 [vdr] Text2Skin: channelInfo display update thread ended (pid=4472, tid=10698759)
--- cut ---

I have in my runvdr script the line:
      export LD_ASSUME_KERNEL=2.4.1
      
What is here the problem?
Has anyone an idea, how to solve this problem?

-- 
Bye
Matthias



More information about the vdr mailing list