[vdr] Problems with vdr-burn and a solution

Ville Skyttä ville.skytta at iki.fi
Tue Jun 14 08:01:03 CEST 2005


On Tue, 2005-06-14 at 07:36 +0300, Jani Frilander wrote:

> I had a problem with burning dvd's from my recordings on my
> system. The system is a FC3 based, and VDR and DVB packages are
> installed from cachalot repository.
> 
> Some version information of conversion software:
> mjpegtools-1.6.3-0.lvn.0.1.rc1
> y4mscaler-0.6.2-0.lvn.1
> ImageMagick-6.2.2.0-2.fc3
> vdr-burn-0.0.6g-0.6.pre3
> 
> The problem occured when the burn script started making menu,
> failing the mpeg2enc-command.

Right.

> I managed to burn DVD's changin one (actually two lines) line
> in the script. Here is the patch:

That patch will probably work with the above version combination, but it
will also result in breakage with mjpegtools < 1.6.3.

The root cause is that you're not using compatible (well, or "same
generation") versions of mjpegtools and y4mscaler.  If you have
mjpegtools >= 1.6.3-RC1, you should be using y4mscaler 8.1, not 0.6.2.

I've just (re-)uploaded it for FC3.   Note also that I'm currently
slowly rebuilding and adjusting everything for FC4 and purging the FC3
repository.




More information about the vdr mailing list