[vdr] replay audio record, fastrewind, play: firmware hangs

Wolfgang Rohdewald wolfgang at rohdewald.de
Wed Jun 15 03:42:40 CEST 2005


hi,

I am using vdr 1.3.25 unpatched with the latest beta firmware 261e.
This is what I get after having added a little bit more debug output showing
the SubStreamType.

The SubStreamType found varies. The record is not pre 1.3.19.

This happens _only_ after fastrewind/play, fastforward/play works correctly.

I'd say there is a bug in vdr which triggers a bug in the firmware
(assuming the firmware should never hang on wrong input)

Also, are those messages "SetBrokenLink..." really needed for pure audio records?

vdr ignores timeouts on OSDSetBlock and similar functions. Shouldn't it rather
do something like restart itself and the driver? (up to now the driver never 
returned error codes for these functions but the CVS drivers now do so)

Jun 15 03:19:28 mm vdr[28881]: playing '/var/lib/video/ARD-Nachtkonzert/2005-04-15.02.04.50.50.rec/001.vdr'
Jun 15 03:19:28 mm vdr[29121]: dvbplayer thread started (pid=29121, tid=147463)
Jun 15 03:19:28 mm vdr[29121]: resuming replay at index 25211 (0:16:48.12)
Jun 15 03:19:28 mm vdr[29122]: non blocking file reader thread started (pid=29122, tid=163848)
Jun 15 03:19:28 mm vdr[29121]: SetBrokenLink: no video packet in frame
Jun 15 03:19:28 mm vdr[29121]: setting audio track to 33
Jun 15 03:19:36 mm vdr[29121]: SetBrokenLink: no video packet in frame
Jun 15 03:19:37 mm vdr[29121]: switching to pre 1.3.19 Dolby Digital compatibility mode,SubStreamType:176
Jun 15 03:19:37 mm vdr[29121]: setting audio track to 33
Jun 15 03:19:45 mm vdr[29121]: ERROR: incomplete PES packet write!
Jun 15 03:19:46 mm kernel: dvb-ttpci: warning: timeout waiting in LoadBitmap: 0, 1
// -110 is -ETIMEDOUT
Jun 15 03:19:46 mm kernel: dvb-ttpci: OSDSetBlock(): returns -110

Jun 15 03:17:33 mm vdr[27579]: SetBrokenLink: no video packet in frame
Jun 15 03:17:35 mm vdr[27579]: SetBrokenLink: no video packet in frame
Jun 15 03:17:35 mm vdr[27579]: switching to pre 1.3.19 Dolby Digital compatibility mode,SubStreamType:0
Jun 15 03:17:35 mm vdr[27579]: setting audio track to 33
Jun 15 03:17:37 mm vdr[27579]: SetBrokenLink: no video packet in frame
Jun 15 03:18:32 mm vdr[27580]: non blocking file reader thread ended (pid=27580, tid=163848)
Jun 15 03:18:33 mm vdr[27579]: dvbplayer thread ended (pid=27579, tid=147463)
Jun 15 03:18:33 mm vdr[27517]: switching to channel 2
Jun 15 03:18:33 mm vdr[27973]: transfer thread started (pid=27973, tid=180231)
Jun 15 03:18:33 mm vdr[27974]: receiver on device 1 thread started (pid=27974, tid=196616)
Jun 15 03:18:33 mm vdr[27975]: TS buffer on device 1 thread started (pid=27975, tid=213001)
// I believe this is a result of the above bug:
Jun 15 03:18:37 mm vdr[27973]: clearing device because of consecutive poll timeouts
Jun 15 03:18:38 mm vdr[27973]: clearing device because of consecutive poll timeouts
Jun 15 03:18:39 mm vdr[27973]: clearing device because of consecutive poll timeouts

-- 
Wolfgang



More information about the vdr mailing list