[vdr] No picture with Hauppauge Nexus-CA

Sami Taipale sami.taipale at gmail.com
Wed Mar 16 18:53:09 CET 2005


Hi,

I can't seem to get a picture out from vdr. I tried with mplayer
plugin and it doesn't even open the mplayer window. Also tried with a
video cable from the dvb-card's output. That gives me the vdr osd but
no tv picture.

The card works fine when i do

  czap -c zap_channels.conf "YLE TV1" -r

and view the stream with

  mplayer /dev/dvb/adapter0/dvr0


Specs:

Card: Hauppauge WinTV Nexus-CA
Distro: Gentoo
Kernel: 2.6.11
VDR: 1.3.22

Output of dmesg:

saa7146: register extension 'dvb'.
saa7146: found saa7146 @ mem dc8ce000 (revision 1, irq 12) (0x13c2,0x000a).
DVB: registering new adapter (Technotrend/Hauppauge WinTV Nexus-CA rev1.X).
adapter has MAC addr = 00:d0:5c:04:47:0c
dvb-ttpci: gpioirq unknown type=0 len=0
dvb-ttpci: info @ card 0: firm f0240009, rtsl b0250018, vid 71010068,
app 8000261c
dvb-ttpci: firmware @ card 0 supports CI link layer interface
dvb-ttpci: adac type set to 0 @ card 0
saa7146_vv: saa7146 (0): registered device video0 [v4l2]
DVB: registering frontend 0 (ST STV0297 DVB-C)...
dvb-ttpci: found av7110-0.

>From log files:

Mar 16 18:52:10 [vdr] VDR version 1.3.22 started
Mar 16 18:52:10 [vdr] loading /video/setup.conf
Mar 16 18:52:10 [vdr] loading /video/sources.conf
Mar 16 18:52:10 [vdr] loading /video/channels.conf
Mar 16 18:52:10 [vdr] loading /video/timers.conf
Mar 16 18:52:10 [vdr] found 1 video device
Mar 16 18:52:10 [vdr] setting primary device to 1
Mar 16 18:52:10 [vdr] SVDRP listening on port 2001
Mar 16 18:52:10 [vdr] loading /video/themes/sttng-default.theme
                - Last output repeated twice -
Mar 16 18:52:10 [vdr] ERROR: /dev/lircd: Connection refused
Mar 16 18:52:10 [vdr] ERROR: remote control LIRC not ready!
Mar 16 18:55:56 [vdr] switching to channel 1
Mar 16 18:56:01 [vdr] switching to channel 2


>From log files with mplayer & subtitle plugins.:

Mar 15 17:38:34 [vdr] VDR version 1.3.22 started
Mar 15 17:38:34 [vdr] loading plugin: /usr/lib/vdr/libvdr-mplayer.so.1.3.22
Mar 15 17:38:34 [vdr] loading plugin: /usr/lib/vdr/libvdr-subtitles.so.1.3.22
Mar 15 17:38:34 [vdr] loading /video/setup.conf
Mar 15 17:38:34 [vdr] loading /video/sources.conf
Mar 15 17:38:34 [vdr] loading /video/channels.conf
Mar 15 17:38:34 [vdr] loading /video/timers.conf
Mar 15 17:38:34 [vdr] found 1 video device
Mar 15 17:38:34 [vdr] initializing plugin: mplayer (0.9.10): Media
replay via MPlayer
Mar 15 17:38:34 [vdr] loading /video/plugins/mplayersources.conf
Mar 15 17:38:34 [vdr] WARNING: removing trailing '/' from base /tmp/
Mar 15 17:38:34 [vdr] initializing plugin: subtitles (0.3.7): DVB
subtitles decoder
Mar 15 17:38:34 [vdr] setting primary device to 1
Mar 15 17:38:34 [vdr] SVDRP listening on port 2001
Mar 15 17:38:34 [vdr] loading /video/themes/sttng-default.theme
Mar 15 17:38:34 [vdr] starting plugin: mplayer
Mar 15 17:38:34 [vdr] starting plugin: subtitles
Mar 15 17:38:34 [vdr] loading /video/plugins/subchannels.conf
Mar 15 17:38:34 [vdr] loading /video/themes/sttng-default.theme
Mar 15 17:38:34 [vdr] ERROR: /dev/lircd: No such file or directory
Mar 15 17:38:34 [vdr] ERROR: remote control LIRC not ready!
Mar 15 17:38:45 [vdr] switching to channel 1
Mar 15 17:39:46 [vdr] channel 4 (YLE24) event 17:10 'Basaren' status 4
Mar 15 17:39:46 [vdr] channel 5 (YLE Teema) event 17:30 'YLE Foorumi' status 4


Any help is greatly appreciated :-)

-Sami-



More information about the vdr mailing list