[vdr] Update for NTSC problem

Vladimir Shved vshved at logistic-systems.com
Tue Mar 29 20:39:18 CEST 2005


I get exact same problem if I load drivers without NTSC patch, make sure the
patched drivers are loaded instead of non-patched. On my system I've built
kernel and DVB drivers as modules. After system starts I unload kernel
drivers and load patched dvb-kernel drivers from CVS.
(dvb-kernel/build-2.6/insmod.sh unload; dvb-kernel/build-2.6/insmod.sh load)
Check with "lsmod" to make sure all DVB drivers unloaded after "insmod.sh
unload", if something is not unloaded, add it to the script for unloading.

> -----Original Message-----
> From: vdr-bounces at linuxtv.org [mailto:vdr-bounces at linuxtv.org] On Behalf
> Of Andrey Vlassov
> Sent: Tuesday, March 29, 2005 11:30 AM
> To: vdr at linuxtv.org
> Subject: [vdr] Update for NTSC problem
> 
> Hi,
> 
> I have described my problem with NTSC output for North America in my
> previous post. I did apply suggested patch but it didn't solve my
> problem. Now I would like provide more details for the problem.
> 
> If I start VDR without tuning to any channel I will get "rolling"
> picture on TV in B/W (it looks like PAL mode). But if I use szap and
> tune the DVB-S card to some channel I will get correct picture on the
> screen of TV. Then if I start VDR and tune same channel I will get
> correct picture/sound.  So, it looks like if the card find signal it
> will work in NTSC mode (weird behavour).
> 
> Other problem I found is that if I switch between channels on the same
> transpoder I will get picture/sound (TV channel) or sound (Radio
> channel). If I am on radio channel I have "rolling" screen and B/W
> picture. It looks like I am in PAL mode again.
> 
> But if I switch to other transpoder I get no picture and no sound and
> "rolling" screen again.
> 
> What is most interesting I never had a problem to tune up by using szap
> program but can not do it in VDR. I guess that it somehow can be related
> to patches I applied for plugins I use. I will recompile VDR without
> plugins to see if I am right about it.
> 
> Is there somebody uses same setup as mine for North America? I would
> like to hear about your experience.
> 
> I have next configuration
> 
> CPU: Athlon 1.2GHz
> RAM: 512MB
> OS: Fedora Core 2
> VDR: 1.3.22
> Plugins: rotor remote control
> DVB-S: Nexus-S 2.3
> Location: North America/Canada
> 
> Andy
> 



More information about the vdr mailing list