[vdr] Patch: dxr3plugin OSD don't turn pink

Ville Skyttä ville.skytta at iki.fi
Wed Mar 30 23:16:57 CEST 2005


On Wed, 2005-03-30 at 13:48 +0200, Martin Cap wrote:

> Attached to this posting is a patch which fixes the odd problem making 
> the osd
> turn pink after returning from mplayer or after hardware-reset of the 
> dxr3-card.
> I posted this fix in a german-vdr-forum a couple of months ago and it
> works for other users there, too. I haven't found the time to post it 
> here (other users hadn't either:) )...  so,
> here it is.

Yep, works for me too, thanks.

However, the patch gave me the creeps, so I dug a little deeper.  I
found that the only thing needed to fix the pink OSD here was to comment
out the "m_users[i] == 0" test in AddColor() and unconditionally setting
m_changed to true there, or to set it to true in GetIndex() when the
color was found.  Both of those were still ugly.  Then I noticed that
the counters in m_users were not being reset to zero when they IMO
should have been, and came up with the attached patch which I think
would be more appropriate.  (Also applied to the vdr-dxr3-0-2 branch in
CVS.)

With this one applied, I no longer get pink OSD after returning from the
MPlayer plugin.  But after "Reset DXR3", the OSD is still momentarily
pink immediately after; things return to normal when the OSD is
hidden/shown again.

Reviews/testing welcome...
-------------- next part --------------
A non-text attachment was scrubbed...
Name: vdr-dxr3-nopink.patch
Type: text/x-patch
Size: 1494 bytes
Desc: not available
Url : http://www.linuxtv.org/pipermail/vdr/attachments/20050331/257b90ef/vdr-dxr3-nopink.bin


More information about the vdr mailing list