[vdr] no sound with nova-t and dxr3

Andre Bischof a.bischof at gmx.net
Sat Oct 22 20:07:52 CEST 2005


Ville Skyttä wrote:
...
> The dxr3 plugin itself uses only avcodec.h and libavcodec*.so from
> ffmpeg.

On my system I can find:

root at linux:/usr/lib# la libav*
lrwxrwxrwx  1 root root      19 Oct  7 01:23 libavc1394.so.0 -> 
libavc1394.so.0.2.1
-rw-r--r--  1 root root   13744 Jul  8 10:55 libavc1394.so.0.2.1
-rw-r--r--  1 root root 1895496 Apr 22  2005 libavcodec-0.4.8.so
lrwxrwxrwx  1 root root      24 Oct 10 14:28 libavcodec-0.4.9-pre1.so -> 
libavcodec.so.0.4.9-pre1
lrwxrwxrwx  1 root root      19 Oct 22 12:49 libavcodec.so -> 
libavcodec.so.0.0.0
lrwxrwxrwx  1 root root      19 Oct 17 14:38 libavcodec.so.0 -> 
libavcodec.so.0.0.0
-rw-r--r--  1 root root 3287840 Oct 16 17:58 libavcodec.so.0.0.0
lrwxrwxrwx  1 root root      19 Oct 10 14:28 libavcodec.so.0.4.8 -> 
libavcodec-0.4.8.so
-rw-r--r--  1 root root 2101960 Mar 31  2005 libavcodec.so.0.4.9-pre1
-rw-r--r--  1 root root  267100 Apr 22  2005 libavformat-0.4.8.so
lrwxrwxrwx  1 root root      25 Oct 10 14:28 libavformat-0.4.9-pre1.so 
-> libavformat.so.0.4.9-pre1
lrwxrwxrwx  1 root root      20 Oct 22 12:49 libavformat.so -> 
libavformat.so.0.0.0
lrwxrwxrwx  1 root root      20 Oct 17 14:38 libavformat.so.0 -> 
libavformat.so.0.0.0
-rw-r--r--  1 root root  407344 Oct 16 17:58 libavformat.so.0.0.0
lrwxrwxrwx  1 root root      20 Oct 10 14:28 libavformat.so.0.4.8 -> 
libavformat-0.4.8.so
-rw-r--r--  1 root root  351948 Mar 31  2005 libavformat.so.0.4.9-pre1
lrwxrwxrwx  1 root root      18 Oct 22 12:49 libavutil.so -> 
libavutil.so.0.0.0
lrwxrwxrwx  1 root root      18 Oct 17 14:38 libavutil.so.0 -> 
libavutil.so.0.0.0
-rw-r--r--  1 root root   11504 Oct 16 17:58 libavutil.so.0.0.0

>> If it's about 
>>libavcodec/utils, then it could be one the following packages I 
>>installed in different steps, I would suggest libavcodeccvs-dev, which 
>>would mach the version of ffmpeg (see above) best - what do you think?
> 
> 
> Yes, that would be my guess too.  And it's possible that you actually
> won't even need ffmpeg.  libavcodec and libavcodec-dev could be enough.

Well, I'll try and report again. But wait - where should the 
dxr3-plugin's Makefile line

FFMDIR = /usr/local/include/ffmpeg

be pointing too? As I wrote, I have an avcodec.h lying there, I think 
that should match libavcodec, shouldn't it?

>>If you need more information about packages installed please ask
> 
> 
> If you need more help with the packages, it would be more efficient if
> someone actually familiar with Debian would step in here...

I wouldn't interfere here :-) but I think it's not that debian specific 
- your help is still very appreciated! :-)

Thanks so far, I'll write soon what I achieved.
Andre



More information about the vdr mailing list