[vdr] softdevice (directfb) and mplayer plugins

Per Mellander per at mellander.org
Fri Sep 2 18:12:01 CEST 2005


On Fri, 2 Sep 2005 14:59:57 +0100, Tony Houghton wrote
> In <20050902152235.M76763 at mellander.org>, Per Mellander wrote:
> 
> > I have a EPIA M10000 that's running vdr-1.3.30, softdevice and streamdev.
> > 
> > I wanted it to be able to play other than vdr recordings so I installed 
the 
> > mplayer plugin. The problem is that I'm having a hard time getting it to 
> > work. I can play movies by using the fbdev as output ( that's VO=fbdev in 
> > mplayer.sh.conf ). This gives a somewhat uncorrect aspect ratio ;) What I 
> > really wan't to ask is if it's possible to use the directfb output for 
> > mplayer aswell? Choosing directfb gives me a black picture and replaying 
> > stops after a few seconds.
> > 
> > mplayer alone plays correct with -vo directfb
> 
> I used to have problems using the mplayer plugin with softdevice,
>  both using DirectFB on a Matrox G450 TV out, but IIRC mplayer used 
> to run OK and it was VDR that wouldn't work again when mplayer had finished.

I don't even get a picture from mplayer !? I think that the problem you had 
is related to that mplayer does not 'release' the directfb correctly. That 
assumption based on the fact that I get a strange warning/error msg when 
mplayer finish. ( Runned aloned that is. )

> 
> Have you tried the softplay plugin?

No, I'll have a look at it right on.

Thanks,

/Mel



More information about the vdr mailing list