[vdr] compiler error with streamdev plugin

Dominique Dumont domi.dumont at free.fr
Thu Sep 22 21:35:20 CEST 2005


Udo Richter <udo_richter at gmx.de> writes:

> This is not latest CVS streamdev, it must be some older version.

Well, I'm using the latest unstable tarball from Sascha's site.

> Anyway, this is a GCC-4 compatibility issue. GCC4 follows the ISO C++ 
> standard very closely, while GCC3 allowed some non-standard things to 
> pass through.

So far so good, I understand.

> In this case: A friend declaration no longer is a forward declaration, 
> so these operators have to be forward-declared.

:-0 ... [scratching my head] ... Let's try cvs, it will be way faster :o)

I've finally found the cvs instructions from the german wiki
(fortunately, cvs is also spelled 'cvs' in german ;-) ) 

I've managed to compile streamdev (with Deti's patch posted last week)
on my Debian sid box.

Thanks for your help.

Cheers



More information about the vdr mailing list