[vdr] [ANNOUNCE] VDR developer version 1.3.48

Mikko Salo mikko.salo at ppe.inet.fi
Sun Apr 23 21:53:48 CEST 2006


On Sun, 2006-04-23 at 21:13 +0200, Thomas Günther wrote:
> Mikko Salo wrote:
> > /etc/init.d/vdr start
> > Starting Linux Video Disk Recorder: vdr
> > Searching for plugins (VDR 1.3.48/1.3.47):find: warning: Unix
> > filenames usually don't contain slashes (though pathnames do).  That
> > means that '-name libvdr-*.so.1.3.48/1.3.47' will probably evaluate to
> > false all the time on this system.  You might find the '-wholename'
> > test more useful, or perhaps '-samefile'.  Alternatively, if you are
> > using GNU grep, you could use 'find ... -print0 | grep -FzZ
> > libvdr-*.so.1.3.48/1.3.47'.
> > sed: -e expression #1, char 47: unknown option to `s'
> 
> 
> This problem is debian specific and will be fixed in the 1.3.48 release.
> 
> Use this patch:
> 
> --- vdr/vdr/trunk/debian/plugin-loader.sh	2006-04-23 14:58:18 UTC (rev 2475)
> +++ vdr/vdr/trunk/debian/plugin-loader.sh	2006-04-23 16:12:44 UTC (rev 2476)
> @@ -32,6 +32,7 @@
>      echo -ne "\nSearching for plugins (VDR $version):"
>  
>      # find installed plugins
> +    version=`echo "$version" | sed 's:.*/::'`
>      plugins=(`find ${PLUGIN_DIR} -maxdepth 1 \
>                     -name "${PLUGIN_PREFIX}*.so.${version}" | \
>                xargs -r dpkg -S 2>&1 | \
> 

Thank you!

Working fine again, sorry for the trouble.

-Mikko




More information about the vdr mailing list