[vdr] Problem compiling xine-0.7.7

Reinhard Nissl rnissl at gmx.de
Thu Feb 16 22:25:57 CET 2006


Hi,

vdr at digestive.jpl.se wrote:

> I'm having problems compiling xine-0.7.7 (vdr-1.3.42) when I run make 
> plugins I get:
> Plugin xine:
> make[1]: Entering directory `/usr/src/vdr-1.3.42/PLUGINS/src/xine-0.7.7'
> g++ -O2 -g -Wall -Woverloaded-virtual -fPIC -c -D_GNU_SOURCE 
> -DPLUGIN_NAME_I18N='"xine"' -DFIFO_DIR=\"/tmp/vdr-xine\" 
> -DSET_VIDEO_WINDOW `xine-config --cflags`  -I../../../include 
> -I../../../../DVB/include xineOsd.c
> xineOsd.c: In member function `void 
> PluginXine::cXineOsd::ReshowCurrentOsd(bool, int, int, int, int)':
> xineOsd.c:103: error: `vidWin' undeclared (first use this function)
> xineOsd.c:103: error: (Each undeclared identifier is reported only once 
> for each function it appears in.)
> xineOsd.c: In member function `virtual void 
> PluginXine::cXineOsd::Flush()':
> xineOsd.c:304: error: `vidWin' undeclared (first use this function)
> make[1]: *** [xineOsd.o] Fel 1
> make[1]: Leaving directory `/usr/src/vdr-1.3.42/PLUGINS/src/xine-0.7.7'
> 
> I have installed xine from Reinhard Nissl's CVS-tarball and my old 
> 0.7.6 (vdr-1.3.36) works correctly with the new xine after I've 
> recompiled the plugin.
> 
> Is there anyone that have a hint what I've done wrong?

You have enabled

	# enable to fully support yaepg plugin
	#VDR_XINE_SET_VIDEO_WINDOW = 1

in vdr-xine's Makefile (or maybe via VDR's Make.config), but you did not 
  apply the necessary patch to VDR which came with the yaepg plugin.

To get it working, either disable this option or install the yaepg 
plugin and patch VDR accordingly.

Bye.
-- 
Dipl.-Inform. (FH) Reinhard Nissl
mailto:rnissl at gmx.de



More information about the vdr mailing list