[vdr] VDR version 1.3.38 incompatible with vdradmin?

Dave P vdr at pickles.me.uk
Sun Jan 8 15:09:21 CET 2006


On Sunday 08 Jan 2006 13:51, Klaus Schmidinger wrote:

> The version number of EPG events is now also stored in the epg.data
> file. Sorry, I forgot to mention that this, of course, also has an
> impact on the LSTE command.

OK, here's a quick-and-dirty patch to restore functionality to vdradmin 
0.97-am3.4.2 (this will word-wrap).

--- vdradmind.pl        2005-12-10 12:17:01.000000000 +0000
+++ vdradmind.my.pl     2006-01-08 14:02:42.000000000 +0000
@@ -735,7 +735,7 @@
                        else {
                                $bc++;
                                while($_ = $SVDRP->readoneline) {
-                                       if(/^E (.*) (.*) (.*) (.*)/ || /^E 
(.*) (.*) (.*)/) {
+                                       if(/^E (.*?) (.*?) (.*?) /) {
                                                my($event_id, $time, 
$duration) = ($1, $2, $3);
                                                my($title, $subtitle, 
$summary);
                                                while($_ = 
$SVDRP->readoneline) {

It's also compatible with earlier versions.
-- 
Dave



More information about the vdr mailing list