[vdr] Re: softdevice & nvidia overlay issues (Niko Mikkila)

Stefan Lucke stefan at lucke.in-berlin.de
Wed Jun 28 00:08:42 CEST 2006


On Dienstag 27 Juni 2006 22:18, CR wrote:
> Hi Niko,
> 
> Niko Mikkila wrote:
> 
> >
> > What's so dumb about that? The video blitter does about the same thing and more
> > through the same old XVideo extension. Actually the blitter has much better
> > scaling quality and is a lot faster than the overlay on my old Riva TNT 2. It
> > also seems that the open source driver uses the blitter as the default XVideo
> > adapter, and doesn't even offer overlay, at least on my card. AFAIK the only
> 
> > Video textures through OpenGL seem to be the way to go since that allows
> > hardware alpha blending for OSD among other effects.
> 
> Are you using one of these newer nVidia cards with VDR/softdevice?  Would
> you share your settings and experiences with it?  Using the psuedo setting
> for OSD I would get blinking video.  Using the "software" setting I would
> get OSD but the colors were wrong during DVD playback.

To see which Xv ports are available, show us the output of command: xvinfo .
For some cards switching between texture and overlay port can be done via
X11 configuration parameters.
For matrox cards it is: Option       "TexturedVideo" "true"

> 
> Yes video textures through OpenGL is a wonderful idea, but what in VDR
> land supports that?  Softdevice (according to another list member) doesn't
> support XvMC so I assume it falls back on overlay support for OSD.

I've Ogl running with mesa here, but it is using much more cpu than xv
30% - xv; 60 % ogl :-( . Blending OSD works, but I loose sync and frames
when OSD gets an update for each displayed video frame, like 
vdr's recording info.

-- 
Stefan Lucke



More information about the vdr mailing list