[vdr] softdevice & nvidia overlay issues

Herbert Poetzl herbert at 13thfloor.at
Thu Jun 29 03:09:08 CEST 2006


On Mon, Jun 26, 2006 at 11:40:06PM +0200, Stefan Lucke wrote:
> On Montag 26 Juni 2006 13:28, CR wrote:
> > Hi,
> > 
> > I'm using VDR 1.4.0-2, softdevice cvs 2006-5-30, nVidia 6200TC
> > video card, nVidia binary driver 8762, Xorg 6.8.1, TV-out (NTSC) @
> > 800x600x24bpp, GCC 4.1.1 .
> 
> Newer nvidia cards do not support Overlay mode:
> http://lists.berlios.de/pipermail/softdevice-devel/2006q1/001770.html
> 
> > For OSD, if I use "psuedo", in full-screen mode, the entire OSD
> > "blinks" when there is video and the OSD is not usable. If I use
> > "software" for OSD setting, then OSD looks OK but when overlayed
> > over video, OSD colors are all wrong.
> 
> Wrong OSD color only ?
> Or both video and OSD ?

here both were wrong ...

> Use softdevice setup OSD and try to change the HUE value to max (100).

yep, changing HUE to 0 or 100 works fine here
hope this works for others too ...

thanks,
Herbert

> If you can read german, have a look at this:
> http://www.vdr-portal.de/board/thread.php?threadid=49914&hilight=nvidia+AND+softdevice
> 
> > 
> > Has anyone else experienced anything like this?
> > 
> > I've seen similar behavior on a TNT2 using the opensource "nv" driver, and
> > other bizarre problems using ATI cards (both opensource and ATI
> > proprietary drive), so I think something in softdevice OSD code is
> > incorrect.
> 
> Radeons (rv280:9200 and rv350:9550) work fine even with pseudo mode
> using Xorg 7.0 here. The limitation in pseudo mode is, that it is not a real
> alphablend mode.
> 
> -- 
> Stefan Lucke
> 
> _______________________________________________
> vdr mailing list
> vdr at linuxtv.org
> http://www.linuxtv.org/cgi-bin/mailman/listinfo/vdr



More information about the vdr mailing list