[vdr] Compile warning fix for xine-0.7.7 and vdr-1.3.44

Darren Salt linux at youmustbejoking.demon.co.uk
Fri Mar 3 23:01:25 CET 2006


I demand that Reinhard Nissl may or may not have written...

> Darren Salt wrote:
>> I demand that C.Y.M may or may not have written...
>>> I noticed some warnings when compiling xine-0.7.7 and vdr-1.3.44.  Here
>>> is a patch.
>> I'm *not* seeing these warnings. Which version of g++, what options? (I'm
>> using g++ 4.0.3 20060212 (Debian 4.0.2-9); I've tried -Wall -Wextra.)

> Well, it is reported on my system with
> 	gcc version 4.0.2 20050901 (prerelease) (SUSE Linux)
> and
> 	-O0 -g3 -Wall -Woverloaded-virtual -Wformat=2 -Wextra
[snip]

With -Woverloaded-virtual, I'm seeing these warnings. I think that I'll start
using that one...

-- 
| Darren Salt    | linux or ds at              | nr. Ashington, | Toon
| RISC OS, Linux | youmustbejoking,demon,co,uk | Northumberland | Army
|   <URL:http://www.youmustbejoking.demon.co.uk/progs.packages.html>

In charity there is no excess.



More information about the vdr mailing list