[vdr] RE: [ANNOUNCE] vdr-skinsoppalusikka-0.0.6

Martin Dauskardt md001 at gmx.de
Mon Mar 27 10:01:55 CEST 2006

I want to use it with LinVDR (with is based on gcc 2.95), but the old
compiler makes problems:

g++ -fPIC -g -O2 -Wall -Woverloaded-virtual -c -D_GNU_SOURCE -DPLUGIN_NAME_I
18N='"skinsoppalusikka"' -I../../../include -I../../../../DVB/include
In file included from
                 from logo.h:12,
                 from skinsoppalusikka.c:12:
76: redefinition of `template <class _Tp> void swap(_Tp &, _Tp &)'
../../../include/vdr/tools.h:52: `template <class T> void swap(T &, T &)'
previously declared here
76: redefinition of `void swap(_Tp &, _Tp &)'
../../../include/vdr/tools.h:52: `void swap(T &, T &)' previously defined
make[1]: *** [skinsoppalusikka.o] Error 1

Is there a possibility for a fix to compile with gcc 2.95 ?

More information about the vdr mailing list