[vdr] vdr-xine, xine-lib and XvMCNVIDIA

Luis Palacios luis at derqui.net
Tue Mar 28 11:58:15 CEST 2006


Sorry if this is not the correct forum, but don't know where to ask
and can't find anything in 'google' :-/

I'm trying to compile my xine-lib with XvMCNVIDIA support but it
doesn't recognizes that I have such library in my system.

AFAIK my system should support XvMC:
  - Pentium 4 with GeForce 6800 LE
  - xorg-x11-6.8.2-r6
  - nvidia-kernel-1.0.8178-r3
  - nvidia-glx-1.0.8178-r1
  $ DISPLAY=:0.1 xdpyinfo | grep XVideo
     XVideo
     XVideo-MotionCompensation    <== !!!

I'm using the last library recommended by Reinhard:
http://home.vr-web.de/~rnissl/xine-lib-cvs-20060319194500.tar.bz2

I have these libraries:
$ ls -al /usr/lib/*XvMC*
-rw-r--r--  1 root root  74512 Dec 13 14:58 /usr/lib/libI810XvMC.a
lrwxrwxrwx  1 root root     18 Dec 13 14:58 /usr/lib/libI810XvMC.so - 
 > libI810XvMC.so.1.0
lrwxrwxrwx  1 root root     18 Dec 13 14:58 /usr/lib/libI810XvMC.so.1  
-> libI810XvMC.so.1.0
-rwxr-xr-x  1 root root  75022 Dec 13 14:58 /usr/lib/libI810XvMC.so.1.0
-rw-r--r--  1 root root   8332 Dec 13 14:58 /usr/lib/libXvMC.a
lrwxrwxrwx  1 root root     14 Dec 13 14:58 /usr/lib/libXvMC.so ->  
libXvMC.so.1.0
lrwxrwxrwx  1 root root     14 Dec 13 14:58 /usr/lib/libXvMC.so.1 ->  
libXvMC.so.1.0
-rwxr-xr-x  1 root root  12275 Dec 13 14:58 /usr/lib/libXvMC.so.1.0
-rw-r--r--  1 root root 183412 Mar 25 11:03 /usr/lib/libXvMCNVIDIA.a
lrwxrwxrwx  1 root root     25 Mar 25 16:34 /usr/lib/libXvMCNVIDIA.so  
-> libXvMCNVIDIA.so.1.0.8178
-rwxr-xr-x  1 root root 170732 Mar 25 11:03 /usr/lib/libXvMCNVIDIA.so. 
1.0.8178
lrwxrwxrwx  1 root root     25 Dec 24 12:38 /usr/lib/ 
libXvMCNVIDIA_dynamic.so.1 -> libXvMCNVIDIA.so.1.0.8178

But when I run 'configure --with-xvmc-lib=XvMCNVIDIA':
[..]
checking for XvMCPutSlice in -lXvMCW... no
*** Could not link with -lXvMCW for vld extensions.
checking for XvMCCreateContext in -lXvMCW... no
*** Could not link with -lXvMCW for standard XvMC.
*** Disabling xxmc plugin due to above errors.
checking whether to enable the xvmc plugin...
checking for XvMCCreateContext in -lXvMCNVIDIA... no
*** Could not link with -lXvMC.
*** Disabling old xvmc plugin due to above errors.
[..]

I'm sure it's probably an easy one, but can't solve it. Can someone  
help me?

thanks a lot,

Luis




More information about the vdr mailing list