[vdr] softdevice and epia tv-out problem with Xorg

Stefan Lucke stefan at lucke.in-berlin.de
Wed Nov 1 22:53:49 CET 2006


Quoting Leo Márquez <leo at calidae.net>:

> Hi Stefan and thanks for your answer.
> I have solved the problem starting softdevice in full screen.

So "-vo xv:full" worked.

> But after started it without problems now I get:
>
> [softdevice] A/V devices initialized, now initializing MPEG2 Decoder
> X Error of failed request:  BadValue (integer parameter out of range for
> operation)
>   Major opcode of failed request:  145 (MIT-SHM)
>     Minor opcode of failed request:  3 (X_ShmPutImage)
>       Value in failed request:  0x3ff

Which are the startup options now ?
0x3ff = 1023 = 1024 - 11

Did you changed your X resolution via "ALT"+"CTRL"+"Keypad +" ?
can you show us the output of command xdpyinfo ?
Which osd_image size was reported in that case ?

>         Serial number of failed request:  250
>           Current serial number in output stream:  251
>
> I have seen that is another value in failed request: 0x33ff.
> I have tried with OSDAlphablend value to 1 without luck.
> What is the 0x33ff value related to?
>
> Thanks.
>
> Stefan Lucke escribió:
>
> >Quoting Leo Márquez <leo at calidae.net>:
> >
> >
> >
> >>Hi!,
> >>
> >>Recently I have connected my vdr box to my CRT 16:9 TV. I use the
> >>s-video(I want to use the rca tv-out for digital audio) connector of my
> >>epia M.10000.
> >>
> >>I have followed some instructions to configure xorg with s-video out
> >>from this page:
> >>
> >>http://www.kingcot.eclipse.co.uk/unichrome/unichromeTvOut.html
> >>
> >>I don't know if this url is up to date.
> >>I have got see my wmaker desktop in my tv but when I start vdr with
> >>softdevice I get:
> >>
> >>[softdevice] initializing Plugin
> >>[softdevice] Initializing Video Out
> >>[softdevice] ffmpeg build(3345920)
> >>[XvVideoOut]: osd_image shmid = 2686978
> >>[XvVideoOut]: got osd_image: width 720 height 576, bytes per line 2880
> >>[softdevice] Subplugin successfully opend
> >>[softdevice] Video Out seems to be OK
> >>[softdevice] Initializing Audio Out
> >>[softdevice] Audio out seems to be OK
> >>[softdevice] A/V devices initialized, now initializing MPEG2 Decoder
> >>X Error of failed request:  BadValue (integer parameter out of range for
> >>operation)
> >>Major opcode of failed request:  145 (MIT-SHM)
> >>Minor opcode of failed request:  3 (X_ShmPutImage)
> >>Value in failed request:  0x2ff
> >>
> >>
> >
> >0x2ff = 767 = 768 - 1
> >768 is the default startup width.
> >
> >So you can try to:
> >a. start in full screen mode "-vo xv:full", which adjusts width and
> >   height to available max values (720 width in your case I guess).
> >b. choose software OSD blending (via OSD :-( ) or via setup.conf:
> >   softdevice.OSDalphablend = 1
> >
> >
> >
> >>Serial number of failed request:  337
> >>Current serial number in output stream:  338
> >>
> >>
> >>
> >

Stefan Lucke



More information about the vdr mailing list