[vdr] FF card A/V sync suggestion

Oliver Endriss o.endriss at gmx.de
Sat Oct 21 14:58:07 CEST 2006


Udo Richter wrote:
> Tero Siironen wrote:
> > However, like Pasi Juppo told earlier in other thread, in last weeks episode
> > of Lost there was many fadeout-fadeins between scenes and a/v desync
> > happened on every one of these.
> 
> I've 'heard of such problems' on ATV+ and Lost. Whenever there's a fade 
> into black, the data stream seems to get stuck, frames get delayed, and 
> as consequence A/V desyncs and playback gets jerky, with lots of audio 
> and video frame drops. This can be fixed by pausing and jumping a few 
> frames backwards.
> 
> My theory is that since audio is typically 600ms ahead of video, maybe 
> the audio buffers run over. Strange thing is why this happens 
> reproducible on blackness. Maybe due to extremely low bit rate in this 
> situation, more frames get packed into one data block, causing data flow 
> to be disturbed beyond some limit. It cant be too high data rate, ATV+ 
> has just 2mbit avg, 4mbit max data rate.

Does it also occur with the latest test firmware?
  http://www.suse.de/~werner/test_av-f22623.tar.bz2

If yes, please provide short sample clips.
Please verify that the clips are not damaged, i.e. they play fine with
mplayer or xine.

Oliver

-- 
--------------------------------------------------------
VDR Remote Plugin 0.3.8 available at
http://www.escape-edv.de/endriss/vdr/
--------------------------------------------------------




More information about the vdr mailing list