[vdr] FF card A/V sync suggestion

C.Y.M syphir at syphir.sytes.net
Tue Oct 24 13:44:59 CEST 2006


Joerg Knitter wrote:
> Klaus Schmidinger wrote:
>> C.Y.M wrote:
>>> Since it has been several years now and I have never been able to
>>> solve the a/v
>>> desync issues with my Nexus-S FF card when playing back recordings...
>>
>> I'm replaying many recordings (actually most of what I watch
>> are recordings ;-) and don't even remember when was the last
>> time I had an A/V desync.
> 
> There is one more issue, that seems to be related. On some recordings,
> here RTL Television with AC3 playback, sometimes single frames seem to
> be skipped during playback. I watched a recording of "Alarm für Cobra
> 11" yesterday and could identify at least 6 little jumps.
> 
> I have isolated a 20 MByte part of this recording where this effect was
> clear to see - I can send it by seperated mails or upload it somewhere
> if someone gives me an URL.
> 
> The weird thing: Playing those isolated scenes does not show the effect
> as people can see if they play the whole recording from the beginning,
> but rewinding the short clip to a certain point makes it possible to
> reproduce the problem. And again: This just happens when playing back
> the AC3 audio track.
> 

Somehow, mplayer is able to detect the areas in the VDR recordings that need
extra "padding" to keep the sync.  There must be some kind of pattern in the
data that the player recognizes and it knows it must insert a null frame.  How
to go about finding how it works and creating an algorithm.

Best Regards.




More information about the vdr mailing list